• Unable to install module zfs


    After the recent updated to the zfs package I am unable to install the zfs model. When I try to install/reinstall zfs I get the following output:

    warning: zfs-0.7.10git+7ec2b1c-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) zfs-0.7.10git+7ec2b1c-1
    
    Total Installed Size:  48.63 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] 
    (1/1) checking keys in keyring                                                                                           [########################################################################] 100%
    (1/1) checking package integrity                                                                                         [########################################################################] 100%
    (1/1) loading package files                                                                                              [########################################################################] 100%
    (1/1) checking for file conflicts                                                                                        [########################################################################] 100%
    (1/1) checking available disk space                                                                                      [########################################################################] 100%
    :: Running pre-transaction hooks...
    (1/1) Remove DKMS modules
    :: Processing package changes...
    (1/1) reinstalling zfs                                                                                                   [########################################################################] 100%
    :: Running post-transaction hooks...
    (1/2) Install DKMS modules
    /usr/src/zfs-0.7.10/dkms.conf: line 50: lsb_release: command not found
    /usr/src/zfs-0.7.10/dkms.conf: line 50: lsb_release: command not found
    /usr/src/zfs-0.7.10/dkms.conf: line 50: lsb_release: command not found
    /usr/src/zfs-0.7.10/dkms.conf: line 50: lsb_release: command not found
    ==> Unable to install module zfs/0.7.10 for kernel 4.14.68-1-lts: Missing dependency.
    ==> Unable to install module zfs/0.7.10 for kernel 4.18.6-arch1-1-ARCH: Missing dependency.
    (2/2) Arming ConditionNeedsUpdate...
    No database errors have been found!
    

    I have check and the spl model is installed and this seem to be an issue with both the lts and standard kernel. Any suggestions on how to resolve or troubleshoot this?

    Thank you for your help

  • @smith_oo4 said in Unable to install module zfs:

    /usr/src/zfs-0.7.10/dkms.conf: line 50: lsb_release: command not found

    lsb-release is installed?

  • I have installed lsb-release and now no longer get the “command not found” message. However I am still not able to install module zfs, output is below. I have both the lts and normal kernel installed and it dose not work for both. Any suggestions on how to resolve or troubleshoot this?

    warning: zfs-0.7.10git+7ec2b1c-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) zfs-0.7.10git+7ec2b1c-1
    
    Total Installed Size:  48.63 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] 
    (1/1) checking keys in keyring                                                                                           [########################################################################] 100%
    (1/1) checking package integrity                                                                                         [########################################################################] 100%
    (1/1) loading package files                                                                                              [########################################################################] 100%
    (1/1) checking for file conflicts                                                                                        [########################################################################] 100%
    (1/1) checking available disk space                                                                                      [########################################################################] 100%
    :: Running pre-transaction hooks...
    (1/1) Remove DKMS modules
    :: Processing package changes...
    (1/1) reinstalling zfs                                                                                                   [########################################################################] 100%
    :: Running post-transaction hooks...
    (1/2) Install DKMS modules
    ==> Unable to install module zfs/0.7.10 for kernel 4.14.68-1-lts: Missing dependency.
    ==> Unable to install module zfs/0.7.10 for kernel 4.18.6-arch1-1-ARCH: Missing dependency.
    (2/2) Arming ConditionNeedsUpdate...
    No database errors have been found!
    
    
  • linux-headers and linux-lts-headers then missing? as you can see it do not give out what is missing now…

    ==> Unable to install module zfs/0.7.10 for kernel 4.14.68-1-lts: Missing dependency.
    ==> Unable to install module zfs/0.7.10 for kernel 4.18.6-arch1-1-ARCH: Missing dependency.
    
  • linux-headers and linux-lts-headers are installed, I just double-checked this. I have the spl DKMS as well and it installs just fine, it is only zfs that is give an issue. Is there a way to look up what is missing, a log or something?

  • May journal for some can give some more info…

    journalctl /usr/bin/dkms
    
  • I tried “journalctl /usr/bin/dkms” and got “-- No entries --”

    I did some googling and came across dkms-sorted in the AUR, which takes dependencies into consideration when rebuilding DKMS modules. This has worked. However, I would have really like to have known what the missing dependency was for my own curiosity.

    Thank you for your help

  • yes would be interesting… may one for dkms was missing, and installing another dkms provider bring all needed deps in ?

unable70 zfs44 module7 Posts 10Views 652
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.