• Can't install necessary packages. Cnchi can't continue - again....


    Re: Can't install necessary packages. Cnchi can't continue.

    Hi I have unfortunately had to install antergos again and have come up with the same issues as have been reported for some time…the pacman boot log is: ====>>>[iso-hotfix-utility] Setting up environment…<<<====
    ====>>>[antergos-iso] Setting up environment…<<<====
    ====>>>[iso-hotfix-utility] We have internet connection.<<<====
    error: could not register ‘multilib’ database (database already registered)
    :: Synchronizing package databases…
    downloading antergos.db…
    downloading core.db…
    downloading extra.db…
    downloading community.db…
    downloading multilib.db…
    resolving dependencies…
    looking for conflicting packages…

    Packages (1) iso-hotfix-utility-1.0.19-2

    Total Download Size: 0.04 MiB
    Total Installed Size: 1.03 MiB

    :: Proceed with installation? [Y/n]
    :: Retrieving packages…
    downloading iso-hotfix-utility-1.0.19-2-any.pkg.tar.xz…
    checking keyring…
    checking package integrity…
    loading package files…
    checking for file conflicts…
    checking available disk space…
    :: Processing package changes…
    installing iso-hotfix-utility…
    :: Running post-transaction hooks…
    (1/1) Arming ConditionNeedsUpdate…
    ====>>>pac() ran with args: -Syy iso-hotfix-utility. Exit status was: 0<<<====
    ====>>>[iso-hotfix-utility] Setting up environment…<<<====
    ====>>>[iso-hotfix-utility] Script has been updated.<<<====
    ====>>>[antergos-iso] Setting up environment…<<<====
    ====>>>[iso-hotfix-utility] We have internet connection.<<<====
    /etc/iso-hotfix-utility.d/antergos-iso: line 191: notify_user: command not found
    error: could not register ‘multilib’ database (database already registered)
    resolving dependencies…
    looking for conflicting packages…

    Packages (1) cnchi-0.14.426-4

    Total Download Size: 4.41 MiB
    Total Installed Size: 10.55 MiB
    Net Upgrade Size: 0.00 MiB

    :: Proceed with installation? [Y/n]
    :: Retrieving packages…
    downloading cnchi-0.14.426-4-any.pkg.tar.xz…
    checking keyring…
    checking package integrity…
    loading package files…
    checking for file conflicts…
    checking available disk space…
    :: Processing package changes…
    upgrading cnchi…
    :: Running post-transaction hooks…
    (1/2) Arming ConditionNeedsUpdate…
    (2/2) Updating the desktop file MIME type cache…
    ====>>>pac() ran with args: -S cnchi. Exit status was: 0<<<====
    2018-06-27 11:16:17 [WARNING] cnchi.py(235) setup_logging(): No module named ‘bugsnag’
    2018-06-27 11:16:17 [INFO] cnchi.py(271) check_gtk_version(): Using GTK v3.22.30
    2018-06-27 11:16:17 [INFO] cnchi.py(283) check_pyalpm_version(): Using pyalpm v0.8 as interface to libalpm v10.0.2
    2018-06-27 11:16:17 [DEBUG] cnchi.py(310) check_iso_version(): Running from ISO version 18.5
    2018-06-27 11:16:17 [INFO] main_window.py(91) init(): Cnchi installer version 0.14.426
    2018-06-27 11:16:17 [DEBUG] main_window.py(119) init(): Cnchi will use ‘/var/cache/pacman/pkg’ as a source for cached xz packages
    2018-06-27 11:16:17 [DEBUG] gtkbasebox.py(61) init(): Loading ‘welcome’ screen
    2018-06-27 11:16:17 [INFO] main_window.py(326) header_for_all_callback(): fired!
    2018-06-27 11:16:29 [INFO] main_window.py(431) on_exit_button_clicked(): Quiting installer…

    pacman conf is:[options]
    Architecture = auto
    SigLevel = Required DatabaseOptional
    LocalFileSigLevel = Optional

    RootDir = /install
    DBPath = /install/var/lib/pacman/
    CacheDir = /install/var/cache/pacman/pkg
    LogFile = /tmp/pacman.log

    Repositories

    [antergos]
    Include = /etc/pacman.d/antergos-mirrorlist

    [core]
    Include = /etc/pacman.d/mirrorlist

    [extra]
    Include = /etc/pacman.d/mirrorlist

    [community]
    Include = /etc/pacman.d/mirrorlist

    [multilib]
    Include = /etc/pacman.d/mirrorlist

    I have tried quite a few fixes in the Antergos forums eg. replacing mirrorlist with the one joekamprad made in June 2018 but these may be outdated. I am in the Uk and I hear that there may be problems with the mirror lists. Any assistance is welcome, thanks

  • welcome to antergos

  • Hi,

    Edit mirrorlists as you might like (using @joekamprad list is fine).

    And then, when installing, please choose “Leave the mirrorlists as they are (by default)”

    Cheers!

  • ok im going to close this and open another topic, im going to try and do some work on grub with any assistance from forum…

cnchi154 packages13 necessary10 continue7 Posts 5Views 575
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.