• XFCE- Laptop with dedicated GPU: External HDMI Display not working


    Re: AntergosPrime - Brings Optimus/ Prime functionality to Antergos

    Hello.

    I installed AntergosPrime according to this thread and everything works fine except when i want to connect a secondary display with HDMI.
    The strange thing is when i switch to the intel gpu, only the laptop display works
    But when i switch to the Nvidia GPU, only my monitor works.

    Never both screens work at the same time though.
    I tried everything. First i installed bumblebee, didn’t work. Then back to the open nouveau driver.
    But always everything works except the second display.

    I Would be very glad if someone knows an answer, thank you.

  • @tastaturri You didn’t say which video card and which laptop you have. There are different types of video switching. Some computers can use both cards at once, some can’t. Some have a specific output that can’t be used at the same time as the laptop screen, but I think those are pretty rare. Also, are you using a dock and are you sure you have all the optimus stuff on in BIOS? I have a Dell that goes either-or with internal screen and side VGA port when it’s docked, solution for that is plug into the dock instead.

    The type of external monitor might matter too. I had a Geforce 560M which needed a bunch of xrandr setup to use a 2560x1440 Asus monitor and XFCE was always a bit glitchy with hotplugging, though it mostly worked after I went into the configuration files and defined settings for devices and screens. It had previously worked just fine with some cheap korean monitor at the same resolution.

    Once I had the display and screen configuration set, XFCE would accept hotplugging, but I’d still have to go into display settings and enable the monitor (or make sure it’s not set to clone) every time I plugged it in. As a warning, don’t set the laptop screen as “not used” unless you need to, or you do some extra setup that I couldn’t figure out. When you unplug the monitor, then you’re still “not using” your only screen, the laptop, and when you plug it back in, XFCE will ask you which screens you’d like to use, but not turn either of them on so you can make the choice. The way I dealt with it was to use the lid switch only to turn off the laptop screen, and when I closed it then reopened it, it would be enabled again.

    Your card is probably newer, so I’ll also mention other issues I had with XFCE as best I can remember: Forgetting to restart the display manager will get you, also make sure you’re set to use either a large enough screen or two separate screens. If you position the 2nd display outside XFCE’s screen area, it won’t work. The whole display/screen thing is a bit counterintuitive for me, so I hope I didn’t say that backwards. The important thing to know is you need to configure both.

xfce73 laptop50 gpu16 dedicated3 Posts 2Views 61
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.