• Issue with Intel gpu


    So I decided to install antergos (KDE) on an old POS795 i had lying around, but after a fresh install the screen just turned off after the GRUB screen. I can boot and log in if i use multi-user.target and i915.modeset=0 but i don’t know how to actually fix the issue since this just turns off my GUI?

  • @lutfisken
    Hi there and welcome to Antergos!

    Usually Intel graphics drivers work very well. Anyway, could you show the following info about your machine (these send the info to pastebin on the internet and return an URL, please show the URL here):

    lspci -vnn > log.txt
    cat /var/log/Xorg.0.log >> log.txt
    cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    And later, if that info proves to be not enough for solving the problem, then you could give this info, too:

    journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1
    
  • @lutfisken
    For me the logs show nothing that could cause the problems.

    Have you already read this: https://wiki.archlinux.org/index.php/Intel_graphics

    Couple of things that might help:

  • @manuel
    I blacklisted the intel modules and Ive already tried most of the stuff on the wiki but it still doesnt work. When i blacklisted the modules the screen no longer turns off but now I get a black screen with the blinking line in the top right corner and i cant do anything except CTRL + ALT + F4 to log in.

  • @lutfisken
    Did you check the files in /etc/X11/xorg.conf.d?

    So if none of the those helped, sorry, I’m out of ideas for now.
    Maybe some other guy here could help you more.

    @joekamprad is the local graphics wizard. :)

  • On newer machines with Intel graphics it is actually recommended to uninstall xf86-video-intel and use the remaining xf86-video-vesa and xf86-video-fbdev.
    This is the case on my machine now.
    But older machines do need the xf86-video-intel driver, and that indeed is the case on another machine here.

    Can’t really say what is “old” and “new” in this respect. Maybe the line goes somewhere between 5 and 10 years now, I guess.

  • Tried that and it still doesnt work, guess Ill just install Ubuntu or Elemental instead. Thanks for the help!

intel42 gpu18 Posts 8Views 317
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.