• Sharing with iPhone


    How do you share your files between your computer and iPhone?
    Got an iPhone, but sharing files without iTunes is almost impossible. Bluetooth is not an option.
    How did you solve the problem?

  • https://wiki.archlinux.org/index.php/IOS

    As far as i know you can connect device as storage device.

  • @joekamprad I got that far, but every time I try to mount an app I get an error—mountpoint does not exist. Maybe you or someone else can explain to me which part of the following line I have to add.
    #ifuse --documents org.videolan.vlc-ios “309”

    #ifuse --documents org.videolan.vlc-ios <mountpoint>
    
  • @axioma
    Hello!
    I just tried for the first time to connect my iPad to my Antergos machine.
    Don’t know if this works with an iPhone, but keep your fingers crossed!

    First I installed packages: ifuse and gvfs-afc. Package libimobiledevice was already installed.

    Then I rebooted Antergos, and physically connected iPad to Antergos box with the USB cable. Then, with Thunar file manager, I could see Firefox downloaded files on the iPad!

    OK, but that wasn’t enough. Firefox files were not the stuff I was looking for.

    Then I edited file /etc/fuse.conf and removed the # sign in front of the line

    #user_allow_other
    

    Somewhere in between I reconnected the USB cable a couple of times before mounting, since mounting didn’t work right away.

    Then I mounted iPad with commands:

    mkdir ~/ios
    ifuse ~/ios -o allow_other
    

    This time it gave no errors, and now I can see some real files under ~/ios folder!

    Cheers! :)

  • Found again the source of the ifuse configuration:
    https://superuser.com/questions/692286/ifuse-mount-iphone-for-different-users-permissions#694625
    The source has a small typo, but my instructions above are OK.

  • I tried the directions by Manuel, but somehow it does still not connect well. I am busy till later next week but will give it a try again.
    Meanwhile using a cloud to transfer files.
    Coming back on this next week.

iphone9 sharing5 Posts 6Views 334
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.