• xorg errors and warnings, leading up to blackscreen


    Heya,

    Been using Antergos for a few good months now, love everything about it.
    One odd thing that started happening recently, yet not consistently, is a blackscreen after suspending the system.
    When it happens, I’m able to switch TTYs using CTRL+ALT+F1/F2/F… etc. That lead me to assuming the problem is with xorg, or alternatively, with xsession.

    I’ve egrep '\((EE|WW)\)' from the xorg logs, finding consistent errors regarding module “intel” and module “synaptics”, alongside some warnings. I’ve attached the logs for further check-ups.

    Would appreciate any insights, it’s such a hassle having to reboot after every suspension, losing a lot of my work.

    Thanks!

  • https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

    System summery and bootlog example:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    
  • @joekamprad Odd, I followed https://forum.antergos.com/topic/1335/how-to-include-system-logs-when-asking-for-help/2 and tried to attach the tar file directly to the post, guess it didn’t work.

    Uploaded the Xorg and Xsession logs here: https://transfer.sh/XQmf8/logs.tar

  • Just a FYI my temporary fix to restart Xorg after switching tty:

    kill -9 `ps a | grep "Xorg :0" | grep -v "grep" | cut -f1 -d" "`
    

    Just to force Xorg and related processes to restart. There might be a better way, but at least it works and I don’t lose my work 🤷

xorg29 blackscreen4 warnings1 leading1 Posts 4Views 245
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.