• Steam Play Beta


    @piotr said in Steam Play Beta:

    @severus said in Steam Play Beta:

    there is something more necessary for the libraries as I recall. If someone needs the exact string I can check it later

    Any advice is welcome.

    I usually set this command

    LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 optirun %command%
    

    for the advanced Launch Options for Steam Games. It was really helpful to me for games which won’t work with the traditional ‘optirun %command%’.

    One exception I found so far, there seems no option to play ‘The last Remnant’ on an Nvidia Card. It runs perfectly on the Intel Graphics in an rather unplayable state. Well Primusrun kind of works for 5 Minutes at max…

  • Thanks!

    LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 optirun %command% does not affect DOOM demo here (still crashes before it really starts). If it comes to “The Witcher 2” (Linux version) - it never starts for me with optirun, and it concerns the line you pasted, too.

    When changed to:

    LD_PRELOAD="libpthread.so.0 libGL.so.1" __GL_THREADED_OPTIMIZATIONS=1 primusrun %command%

    … it starts, but w/o the overlay, so I can’t even see FPS. The game seems to be less responsible, but actually I didn’t play.

    I have no more game installed, so can’t test it better, sorry.

  • Patiently twiddles thumbs and looking at his AMD graphics cards…

    Just hoping LLVM solves the issue on my end, unless there’s some AMD command that someones knows of that I’m unaware of.

  • thanks for sharing this information with us

  • @polomoto said in Steam Play Beta:

    Just hoping LLVM solves the issue on my end

    0_1537356973561_c6edc8a3-3b37-4d8f-85d5-cabb3f03ccaa-image.png

  • @piotr been refreshing that page for days, it’s not on Arch yet though and I don’t trust myself enough to do it manually. Based on earlier updates it should take just a few days.

  • @polomoto With nothing better to do, I also checked at least once a day. :)

  • @piotr Yea it was definitely unhealthy for me lol, I was even digging through the mailing list archives to figure out an estimate. I’m gonna be really disappoint it turns out this wasn’t the issue…

  • @polomoto In my case it’s just art for art. I doubt if buying The Witcher 3 makes sense at all. The Witcher 2 in 1920 x 1080 on my GeForce 930M does not exceed 18 FPS. To see more than 40, I must set 1024 x 576, which looks pitifully. :/

  • @piotr I know it’s a bit late, but steamplay doesn’t work with bumblebee at all. I looked into it and it seems bumblebee doesn’t have support for Vulkan, which Proton needs.

  • @calebq42 I believe that depends on what the game uses. AFAIK OpenGL games will run fine

  • @calebq42 said in Steam Play Beta:

    steamplay doesn’t work with bumblebee at all.

    Dunno how to check is Steam Play works. However, disabling Bumblebee and starting the machine with Nvidia still enabled changes nothing. Doom demo (Windows) still doesn’t start. The Witcher 2 (Linux) works as it did. Maybe during the weekend I’ll try and download some more Windows-only games to test.

  • Just to clarify:

    @calebq42 said in Steam Play Beta:

    steamplay doesn’t work with bumblebee at all

    If I understand well, we should not understand Steam Play as a certain piece of software, which works or does not work inside the Steam platform. This is just the possibility to:

    (…) purchase your games once and play anywhere. Whether you have purchased your Steam Play enabled game on a Mac or PC (both Windows and Linux), you will be able to play on the other platform free of charge.

    The service described above uses Proton, which is a part of Steam for Linux in Beta version. Depending on if we start steam-runtime or steam-native, the version in use may come either from Valve directly, or from repos (AUR in this case).

    Just thinking aloud. Correct me if I’m wrong.

    @polomoto said in Steam Play Beta:

    I believe that depends on what the game uses. AFAIK OpenGL games will run fine

    Judging from lists like this one, you’re probably right.

  • @PoLoMoTo llvm-libs have just got to Arch Testing.

  • @piotr Yaaaaas! I just saw it today, I’m so hype even though I’m so sure that I’m going to be disappointed…

  • @polomoto Well, I installed llvm-lib, lib32-llvm-lib and mesa from Testing, and it changed nothing. I might have missed something, anyway.

  • @piotr Well poop there goes that then, although you got some things to work right? I haven’t been able to get either of the games I have working, and I’m on team red for my graphics cards so I’m still setting my hopes high to be absolutely crushed. Will probably just continue waiting for it to be in stable at this point though.

  • @polomoto I haven’t given a try to any Steam Play game except the DOOM demo so far. I only played The Witcher 2, and launched Star conflict - both prepared for Linux, and they work well. I need to download some more Windows games to learn if Steam Play actually works or not.

  • So I know this topic is old but I’m still working on it. I finally got at least Fallout Shelter running on my machine. The problem seems to be that I did not have the Vulkan drivers for my graphics card installed. I installed all of the AMDGPU drivers including the Vulkan drivers (and enabled Sea Islands support since I have a 290x) and it started right up no problems. I haven’t tried anything else other than Black Ops 3 which did not work but we will see.

    EDIT: Have now also tested Tropico 4 which seemed to work. I also have heard that Fallout: New Vegas works but I have not tried it as I don’t think I have the storage space to install it. I do apparently so I will try that I return with the results. – Fallout: New Vegas does seem to work although I’m not sure how modding would work.

    (Fun side effect of the AMDGPU drivers is also that now my display’s 75hz refresh rate and FreeSync seems to work)

  • The patch notes for the latest Proton actually say they identified a bug with AMD & Intel graphics with Vulkan, and as a workaround have fudged the graphics ID to claim it’s NVidia while they work on a real fix.

    Wonder if that’s what was the root cause of your problems… :)

steam68 beta7 Posts 40Views 2355
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.