• Steam Play Beta


    Has anyone had any luck with any of the new Steam Play beta supported titles? I’ve tried Fallout Shelter and Tropico 4 with no luck. Fallout Shelter gives a not very insightful error and Tropico 4 always performs first time set up but never actually starts afterwards. I was wondering if anyone had success with any of the supported titles and if they had any tips for getting it working.

  • @joekamprad As I said here, I haven’t tested it much so far. Having learnt more, I’ll share my experience in this thread. :)

  • It takes ages to download a game on my connection tonight, so I only managed to try the “Doom” demo. I tried to run it w/ and w/o the optiprime %command% option (optiprime is nothing but the vblank_mode=0 primusrun "[email protected]" command equivalent). The game would not start.

    I changed Proton version to 3.7-5 Beta:

    0_1535763366005_doom02.png

    …and it downloaded an update to the game. It still doesn’t start, however.

  • @piotr I don’t believe that changing the version in that drop down should do anything unless you check the box for “Use this tool instead of game-specific selections from Steam” although I have tried the versions with that box also with still no success.

  • @polomoto On the other hand: somewhere on the web I saw people confirming the Witcher III to work. I would have to risk PLN 99,99. Not tonight. :)

  • @piotr Were they claiming it worked on Arch/Antergos though? I’ve seen people claiming Fallout Shelter too and its on the supported list thats why I tried it. I’m figuring it has to be something to do with Arch but I have no idea what. To be fair I don’t really know or understand how Steam is attempting to run all of this.

  • I may have found an issue. This is not Arch but still something.

    https://github.com/ValveSoftware/Proton/issues/1104

    The response was to try with Mesa 18+ and LLVM 7+. I’m not entirely sure how to correctly check the version I have for either but searching through the Add/Remove Software app it would appear that while I do have Mesa 18, I do not have LLVM 7, I have LLVM 6.0.1. So that may be the issue although I have no idea how to upgrade to LLVM 7.

  • Can’t seem to edit my last post for some reason so I’ll just double post I guess.

    Seems that LLVM 7 is currently in a Release Candidate and will be out on the fifth. Not sure how Ubuntu LTS got it first…

  • You mean llvm-libs and lib32-llvm-libs? They are 6.0.1 on my Arch machine, too. And nothing in testing yet. However, I’ve just found svn packages marked 8.0.0 in AUR, dated 2018-08-23: llvm-libs-svn 8.0.0svn_r340523-1 and lib32-llvm-libs-svn 8.0.0svn_r340523-1. Shame that I deleted DOOM. Maybe I’ll download it again as I’m back home, and give a try to the AUR libs.

  • I tried to build the packages mentioned above. Both end up in errors.

  • @piotr Yea I had seen those packages but the documentation looked like it was all over my head so I decided to not persue it. The 7.0 release should be out on the fifth anyway and I’d imagine arch will get it pretty quick. So I’m just waiting till then to see.

  • Hi,
    I just found this (a bit heated) posting: https://forum.manjaro.org/t/increase-fd-limits-to-let-steam-play-works-reliably/56270

    Don’t know if it helps anything, but someone having issues with Steam Beta might want to try that.
    Note that there may be other issues with this modification… So remove it if you experience new issues because of it.

    I don’t use Steam so I haven’t tried it, so I know nothing more about it.

  • Thanks! I’ll give it a try at home.

    @manuel said in Steam Play Beta:

    I don’t use Steam so I haven’t tried it, so I know nothing more about it.

    Not that I’m a heavy gamer. Actually I only wanted to see one certain game in action. However, I’m strongly interested in seeing on Linux as many commercial games as possible, preferably all of them. Who on earth would use Windows at home any longer?

  • @piotr

    Who on earth would use Windows at home any longer?

    Well, I do… ;)

    I’m keeping Windows for “just in case” situations (so far no such situation has occurred in about 2 years now). And, I’m not really using it, but I keep it updated once a month, not much of a job with it.

    In fact, I could just wipe Windows, because if I ever would need it, I could download an evaluation version from the Microsoft site and install it as a virtual machine.

    But I guess it is easier just to keep it, since I wouldn’t want to install Windows because it takes about a full day with all updates in my experience.

  • @manuel said in Steam Play Beta:

    I’m keeping Windows for “just in case” situations

    The only reason I needed Windows once (last year) was to update firmware in my e-cigarette. :) That’s why I keep the old disk that came with my netbook somewhere in the drawer. But you’ve just given me an idea: I could put it into my main machine, which has never had Windows installed. Provided that it updates drivers and stuff, I could compare FPS in “The Wither 2” on Arch and Windows. Hmmm… Sounds interesting…

  • @manuel Appreciate the suggestion and find. I didn’t have any luck though with Fallout Shelter unfortunately.

  • Is anyone interested in comparison between Win10 and Arch NVIDIA performance? I wasted spent 7 hours to launch Windows on my Asuspro P751JF, and download the game. “The Witcher 2” gives me exactly the same FPS values, measured by the Steam counter.

    I must admit that I breathed a sigh of relief. The performance of my computer is lower than I expected. I was afraid that the Linux NVIDIA driver might be the reason.

  • I’ve had pretty good experiences with Steam Play Beta for now. Although I must admit I haven’t tried too many Games so far.
    But I’ve tried Final Fantasy VII and VIII and they work almost perfectly. A little configuration required for FF VIII cause Background Music doesn’t work Out of the Box.
    So far I only had one game immediately crashing, before even starting.

    Also I always have set the Launch Options to Optirun for Using the Nvidia Card, but there is something more necessary for the libraries as I recall. If someone needs the exact string I can check it later.

  • @severus said in Steam Play Beta:

    there is something more necessary for the libraries as I recall. If someone needs the exact string I can check it later

    Any advice is welcome.

steam68 beta7 Posts 40Views 2356
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.