• Wl drivers (Fatal error)


    My rMBP’s WiFi card is the (Broadcomm) BCM4360, which according to links found on the Arch Wiki requires the wl drivers ([http://wireless.kernel.org/en/users/Drivers/b43#Known_PCI_devices][0]">[http://wireless.kernel.org/en/users/Dri][1] … CI_devices), and the installer won’t let me proceed without an internet connection (either graphical or CLI, although I’d prefer to use a GUI). Unfortunately when I opened up the terminal and ran
    modprobe wl ([https://wiki.archlinux.org/index.php/broadcom_wireless][0]">[https://wiki.archlinux.org/index.php/broadcom_wireless][2])
    I get back a fatal error that they don’t exist. How do I go about resolving this? I’m using a Live USB stick.
    Note: I made sure to use rmmod b43 and rmmod ssh, although it said both were disabled already, but it looks like the b43 drivers are actually in the files since when I tried modprobe b43 and then lsmod they showed up at the top of the list.

    Edit: If I could get the broadcom-wl drivers on a separate flash drive, I assume I could use that to install it, correct? (If I find a solution on google before a response here I’ll link to what I found.)

    Edit 2: Unfortunately, makepkg is leading in circles due to root permissions (procedure followed is from here: [https://wiki.archlinux.org/index.php/Arch_User_Repository#Build_the_package][0]">[https://wiki.archlinux.org/index.php/Ar][3] … he_package):
    [http://i.imgur.com/y4mmo7I.jpg][0]">[http://i.imgur.com/y4mmo7I.jpg][4]

    [0]: <a href=
    [1]: http://wireless.kernel.org/en/users/Dri
    [2]: https://wiki.archlinux.org/index.php/broadcom_wireless
    [3]: https://wiki.archlinux.org/index.php/Ar
    [4]: http://i.imgur.com/y4mmo7I.jpg

  • My rMBP’s WiFi card is the (Broadcomm) BCM4360, which according to links found on the Arch Wiki requires the wl drivers ([http://wireless.kernel.org/en/users/Drivers/b43#Known_PCI_devices][0]">[http://wireless.kernel.org/en/users/Dri][1] … CI_devices), and the installer won’t let me proceed without an internet connection (either graphical or CLI, although I’d prefer to use a GUI). Unfortunately when I opened up the terminal and ran
    modprobe wl ([https://wiki.archlinux.org/index.php/broadcom_wireless][0]">[https://wiki.archlinux.org/index.php/broadcom_wireless][2])
    I get back a fatal error that they don’t exist. How do I go about resolving this? I’m using a Live USB stick.
    Note: I made sure to use rmmod b43 and rmmod ssh, although it said both were disabled already, but it looks like the b43 drivers are actually in the files since when I tried modprobe b43 and then lsmod they showed up at the top of the list.

    Edit: If I could get the broadcom-wl drivers on a separate flash drive, I assume I could use that to install it, correct? (If I find a solution on google before a response here I’ll link to what I found.)

    Edit 2: Unfortunately, makepkg is leading in circles due to root permissions (procedure followed is from here: [https://wiki.archlinux.org/index.php/Arch_User_Repository#Build_the_package][0]">[https://wiki.archlinux.org/index.php/Ar][3] … he_package):
    [http://i.imgur.com/y4mmo7I.jpg][0]">[http://i.imgur.com/y4mmo7I.jpg][4]

    [0]: <a href=
    [1]: http://wireless.kernel.org/en/users/Dri
    [2]: https://wiki.archlinux.org/index.php/broadcom_wireless
    [3]: https://wiki.archlinux.org/index.php/Ar
    [4]: http://i.imgur.com/y4mmo7I.jpg

  • Hi,

    Do you have access to another system that is able to access the internet using the live cd? If yes then here is what you do:

    1. From other system (with internet access), Open gnome-terminal and run these commands:

      
    sudo pacman -Syy base-devel  
    yaourt -G broadcom-wl  
    makepkg -s
    

    2. Copy the pkg to a usb drive (its in /home/antergos)
    3. From your system, disable the wifi connection in System>>Settings and copy the pkg from your usb to /home/antergos.
    4.Run these commands:

    rmmod b43  
    rmmod ssb  
    sudo pacman -U /home/antergos/package-name-here-pkg.tar.xz  
    modprobe wl lib80211 lib80211\_crypt\_tkip
    

    5. Enable wifi connection in System>>Network

    Let me know how it goes

    Cheers!

  • Okay, well on my old laptop I was able to access WiFi and ran

    sudo pacman -Syy base-devel
    

    successfully. The problem is that when I tried to run

    yaourt -G broadcom-wl
    

    it spit back the command doesn’t exist. Running

    man yaourt
    

    reported the command wasn’t in the archives. Instead, I ran

    curl -L -O https://aur.archlinux.org/packages/br/broadcom-wl/broadcom-wl.tar.gz
    

    which did work, and then ran

    tar -xvf broadcom-wl.tar.gz
    

    which again worked. (Side note: running sudo pacman -Syy base-devel listed a set of things I could download, to get the file to package I clicked 5 for fakeroot, it wouldn’t do it originally). Then I ran

    cd /[Broadcom Folder]  
    makepkg -s
    

    and successfully created the package, moved it to my flash drive, and then moved everything over to my actual laptop.

    I went to settings -> network, and there was not option to disable WiFi (there wasn’t even a WiFi option in there, just a box labelled proxy, so instead I just turned on Airplane mode, and assuming it works like it does on my phone, then that should have disabled WiFi.

    Anyways, I ran the rmmod commands, but neither of those modules we’re installed anyway.

    sudo pacman -U [package file]
    

    executed somewhat successfully, it’s easier to show with a photo:
    [http://i.imgur.com/ZUBv22w.jpg][0]">[http://i.imgur.com/ZUBv22w.jpg][1]

    I ran
    [code:2h4nmmnx]lsmod[/code:2h4nmmnx] and it appears that broadcom-wl wasn’t loaded, but somehow libcom80211 was installed.
    [http://i.imgur.com/V3VO3zH.jpg][0]">[http://i.imgur.com/V3VO3zH.jpg][2]
    Anyways, when I went back to settings -> network, nothing had changed, there was no WiFi connection listed.

    Could the package I used be the problem? When I checked the Arch Wiki, it said yaourt is just another repository like Arch, so I could download the package directly, put it on a flashdrive, and use my old computer to make it a .pkg.tar.*z file right?

    Thanks for the help.

    [0]: <a href=
    [1]: http://i.imgur.com/ZUBv22w.jpg
    [2]: http://i.imgur.com/V3VO3zH.jpg

  • You did everything correctly but you missed a few commands. Take another look at #4 from my previous post

    Cheers!

  • @“lots.0.logs”:3algub9s said:

    You did everything correctly but you missed a few commands. Take another look at #4 from my previous post

    Cheers![/quote:3algub9s]

    Actually, I did run the

    modprobe lib80211
    

    commands, if you check my first photo they’re near the bottom. I imagine that’s how the lib80211 module got installed, the odd thing is that the broadcom-wl did not actually get installed.

    Edit-It shows an error in that command, I had previously ran several different iterations of the command (like dropping the wl and etc.) so it probably could have come from that.
    Edit 2: Something that may be of note is that when installing the broadcom-wl command, it says it’s a 2.7 MiB package, but that the net size is 0 MiB, like it wasn’t saving it.

  • Did you run:

    modprobe wl
    

    Also did you remove the other two modules before adding wl?

  • @“lots.0.logs”:2u4xxc8l said:

    Did you run:

    modprobe wl
    

    Also did you remove the other two modules before adding wl?[/quote:2u4xxc8l]

    I ran

    modprobe wl lib80211 lib80211\_crypt\_tkip
    

    As listed in your first post, and I also ran

    modprobe lib80211 lib80211\_crypt\_tkip
    

    When the first code failed. I [i:2u4xxc8l]believe[/i:2u4xxc8l] I also ran

    modprobe wl
    

    but I can’t remember for sure (this was a day or two ago).

    As far as the other modules, I did run the commands, but the modules weren’t installed in the first place, as shown by this picture [http://i.imgur.com/ZUBv22w.jpg][0]">[http://i.imgur.com/ZUBv22w.jpg][1]

    I’m going to try again and see what happens (and I’ll make sure to specifically run modprobe wl and document what happens). Just speculation, but I believe it’s not actually installing the drivers to the live cd for the live CD to load with modprobe, but obviously I don’t have much experience in Arch.

    Thanks again.

    [0]: <a href=
    [1]: http://i.imgur.com/ZUBv22w.jpg

  • Okay, after running sudo modprobe wl, it installed, but now the problem is that rEFInd isn’t recognizing the boot partiton. The Arch wiki says it should be / which is what I did, and holding alt upon start up doesn’t do anything useful (insofar as booting goes) either. I deleted the partitions to start over, so once it stops freezing during the installation process I’ll be able to try again.

  • Hmm… don’t know much about that bootloader. Is using grub not an option for you? The installer sets up grub properly for UEFI systems.

    Cheers!

  • I got it to finally install again, but I’m not familiar with GRUB. What rEFInd does is allow for dual booting, when I restart my laptop it (theoretically) lets me pick which OS I want to boot into, I can select between OS X or Linux Distro whatever, and from there I believe it boots into GRUB, not that it replaces it.

    I should note, I haven’t actually restarted to finish installation yet, I’m trying to find a solution while still working within Antergos rather than being forced to fix it from the other partition (OS X), I have one partition for that, a ~40GB partition for Antergos (mounted as /) and then an 8GB part for swap space.

    Yeah, okay, I restarted after a successful installation: [http://i.imgur.com/GGYf8Rc.png][0]">[http://i.imgur.com/GGYf8Rc.png][1] yet I can’t boot in. Ugh.

    [0]: <a href=
    [1]: http://i.imgur.com/GGYf8Rc.png

  • Okay, I got it to boot, thanks (documentation: I had to reinstall rEFInd with all the drivers, because apparently the ext4 drivers aren’t installed by default for some reason. Don’t ask me why.) Now to get WiFi working again, although this isn’t an installation issue anymore. Thanks for all the help.

Posts 13Views 3025
Log in to reply