• kdesudo depends on orphaned package


    Earlier today I got an update for the kdebase-runtime package, which was orphaned:

    Commit message
    2 hours Dropped from repos

    $  yaourt -R kdebase-runtime
    [sudo] password for username: 
    checking dependencies...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: kdesudo: removing kdebase-runtime breaks dependency 'kdebase-runtime'
    
    

    On my system the package is a dependency for the ‘kdesudo’ which lives the ‘antergos’ repo.

    antergos/kdesudo 3.4.2.4-1 [installed]
        A SUdo frontend for KDE
    

    This package should be updated to reflect these changes.

    PS. Sorry if this is not the place to report the issue

  • @hertjies I tried to updated this morning and found the same thing.

    I simply put it on the Ignore List(until the developers push through the upgrade) . Afterwards the other packages updated normally.

  • @frenchconnection thanks for the advice, will try that

  • Don’t mention it 👍

  • I have a different issue with kdebase today:

    Building kdebase-runtime...
    Cloning into 'kdebase-runtime'...
    remote: Enumerating objects: 6, done.        
    remote: Counting objects: 100% (6/6), done.        
    remote: Compressing objects: 100% (6/6), done.        
    remote: Total 6 (delta 0), reused 0 (delta 0)        
    Unpacking objects: 100% (6/6), done.
    ==> Making package: kdebase-runtime 17.08.3-4
    ==> Checking runtime dependencies...
    ==> Checking buildtime dependencies...
    ==> Retrieving sources...
      -> Downloading kde-runtime-17.08.3.tar.xz...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100   353  100   353    0     0    308      0  0:00:01  0:00:01 --:--:--   308
    100 7719k  100 7719k    0     0   580k      0  0:00:13  0:00:13 --:--:--  911k
      -> Downloading kde-runtime-17.08.3.tar.xz.sig...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100   488  100   488    0     0    642      0 --:--:-- --:--:-- --:--:--   642
      -> Found kdebase-runtime-no-html-thumbnails.patch
      -> Found kdebase-runtime-no-kdewebkit.patch
    ==> Validating source files with sha256sums...
        kde-runtime-17.08.3.tar.xz ... Passed
        kde-runtime-17.08.3.tar.xz.sig ... Skipped
        kdebase-runtime-no-html-thumbnails.patch ... Passed
        kdebase-runtime-no-kdewebkit.patch ... Passed
    ==> Verifying source file signatures with gpg...
        kde-runtime-17.08.3.tar.xz ... FAILED (unknown public key DBD2CE893E2D1C87)
    ==> ERROR: One or more PGP signatures could not be verified!
    
  • @toxpal Same problem me thinks ;-)

    I just took the package off Ignore List and attempted another update via Pamac
    to see what happens and I had the same result… So, same answer as above: put the package on the Ignore List for now :-)

  • @toxpal said in kdesudo depends on orphaned package:

    kdebase-runtime

    is moved to AUR, so Antergos @developers will need to provide this package over Antergos Repo now…

    //as far as i understand//

  • I ran into the same problem and i imported the key by running this command —> gpg --recv-keys DBD2CE893E2D1C87
    below show the results of the command
    ~]$ gpg --recv-keys DBD2CE893E2D1C87
    gpg: key DBD2CE893E2D1C87: 1 signature not checked due to a missing key
    gpg: /home/steve/.gnupg/trustdb.gpg: trustdb created
    gpg: key DBD2CE893E2D1C87: public key “Christoph Feck [email protected]” imported
    gpg: no ultimately trusted keys found
    gpg: Total number processed: 1
    gpg: imported: 1

  • please go here to get involved and udated:

    https://forum.antergos.com/topic/10539/kdebase-runtime-moved-to-aur

    i am closing this one here, to get it all in one place.

    closing

orphaned4 depends1 kdesudo1 Posts 10Views 1153
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.