• Antergos can start with LTS kernel only


    Antergos Linux was installed on Windows 10 on an older HP Compaq desktop. After that, the new system started well. Then I signed up to Grub in Windows 10. Then Antergos was ready to start with only the LTS kernel. Starting with a normal kernel Starting 235 messages appeared after the boot and nothing happened. As old linux user i’m not so confused, but the question is: what could be wrong?

  • If I got it well, you have both kernels installed, but you are only able to enter your system with the LTS one, right?
    If this is the case, there have been some issues reported with the new 4.18-1 kernel. To some users these have been resolved with the 4.18-3 update. I guess you ll have to be a little more patient till a kernel update gets you a fix.
    Cheers

  • This post is deleted!
  • @anarch Thanks. I think this is true. During the installation, i selected the LTS kernel, too, so Iobviously the normal kernel has also been installed. Otherwise, the correct screen message during boot: “starting 239”.

  • @zoli62 said in Antergos can start with LTS kernel only:

    correct screen message during boot: “starting 239”.

    The normal kernel gives you “starting 235” and LTS gives you “starting 239”?

    If so that’s very weird… The message is related with systemd version which should be the same, since you have one system installed…

  • This post is deleted!
  • @fernandomaroto said in Antergos can start with LTS kernel only:

    @zoli62 said in Antergos can start with LTS kernel only:

    correct screen message during boot: “starting 239”.

    The normal kernel gives you “starting 235” and LTS gives you “starting 239”?

    If so that’s very weird… The message is related with systemd version which should be the same, since you have one system installed…

    Then I specify: starting with normal kernel will show “starting 239”. In the opening post I accidentally wrote this wrong.

  • @zoli62
    The non-LTS kernel is installed by default. In order to have the LTS kernel, you have to install it manually (or have explicitly selected it during install).

    But maybe the install of the default kernel is somehow corrupted, could you reinstall it?

    sudo pacman -S linux
    sudo pacman -S linux-headers  # if needed
    
  • @manuel I’m also satisfied with the LTS kernel. During boot with normal kernel after a while this screen message comes: INFO: rcu_preempt detected stalls on CPUs/tasks

  • @zoli62
    Found this old post: https://bbs.archlinux.org/viewtopic.php?id=134249
    Don’t know if it helps, but worth a try.

    It recommends adding this to file /etc/modprobe.d/modprobe.conf:

    # disable autoload of ipv6
    alias net-pf-10 off
    
  • @manuel Thanks. I saw this post as well. In Antergos Linux, there is a LTS kernel for escape from such a kernel failures. Installing this is strongly recommended. I came from Manjaro, where I did not experience this. But I liked the lightness and speed of Antergos Linux and that it is a real Arch, unlike Manjaro.

  • Meanwhile, on another machine where Manjaro is installed, I checked. There is no such error because the 4. 16 kernel is installed. This fact confirms that it is possible kernel bug.

  • In the meantime, I reinstalled kernel 4.18.4, but nothing changed.

  • My problem is solved. Today, kernel 4.18.5 was released, which I installed with the updates. Then I could boot the system with the normal kernel. Otherwise, the problem is not unique. https://bbs.archlinux.org/viewtopic.php?id=239672

  • Joy was early. With the latest kernel the system started once, but no longer.

  • @zoli62
    Do you get any error?
    Is LTS still working at least?

  • @fernandomaroto said in Antergos can start with LTS kernel only:

    @zoli62
    Do you get any error?
    Is LTS still working at least?
    There is no newer error message. In any case, the LTS kernel works.

  • Hopefully the following 4.19 kernel will solve the problem.

  • It looks like the bug in kernel 4.18.10 has been fixed.

kernel125 lts15 Posts 20Views 1051
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.