• rabbitmq stopped working after linux upgrade


    Hi,
    I hope this is the right place for this.
    A few days back my rabbitmq package stopped working. The only way I found to fix it was to downgrade the linux package to version linux-4.18.1.arch-1.

    I noticed this because I’m trying to connect to rabbitmq via py-amqp but I always get ConnectionResetError: [Errno 104] Connection reset by peer

    When I run sudo rabbitmqctl status with any linux version higher than the one mentioned above, I get the following:

    Status of node [email protected] ...
    Error: unable to perform an operation on node '[email protected]'. Please see diagnostics information and suggestions below.
    
    Most common reasons for this are:
    
     * Target node is unreachable (e.g. due to hostname resolution, TCP connection or firewall issues)
     * CLI tool fails to authenticate with the server (e.g. due to CLI tool's Erlang cookie not matching that of the server)
     * Target node is not running
    
    In addition to the diagnostics info below:
    
     * See the CLI, clustering and networking guides on http://rabbitmq.com/documentation.html to learn more
     * Consult server logs on node [email protected]
    
    DIAGNOSTICS
    ===========
    
    attempted to contact: [[email protected]]
    
    [email protected]:
      * connected to epmd (port 4369) on myhostname
      * epmd reports node 'rabbit' uses port 25672 for inter-node and CLI tool traffic
      * TCP connection succeeded but Erlang distribution failed
    
      * Remote host closed TCP connection before completing authentication. Is the Erlang distribution using TLS?
    
    
    Current node details:
     * node name: [email protected]
     * effective user's home directory: /var/lib/rabbitmq
     * Erlang cookie hash: 9MKJprMnMK2BLLXH6++++Q==
    
    

    When checking the logs for rabbitmq, everything seems normal and there is no error visible. Also when running systemctrl status rabbitmq.service eveything looks normal.

    Does anyone know how to fix this problem? I’d like to keep my system up to date all the time, so I’d like to upgrade the linux package sooner or later as well.

  • @annefly
    Did you try using the LTS kernel linux-lts?

  • @manuel thanks a lot, that actually solved it!
    I installed the linux-lts package and then upgraded all my packages including the upgrade to linux 4.18.3.arch1-1. After restarting rabbitmq, it all worked perfectly!

upgrade81 stopped10 rabbitmq1 Posts 3Views 223
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.