• Bluetooth stopped working


    Hi there.
    Since I booted my PC (Dell XPS 15 9550) this morning I haven’t been able to get the bluetooth to work—it worked yesterday.

    When I boot antergos, and run systemctl status bluetooth I get

    * bluetooth.service - Bluetooth service
       Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
       Active: inactive (dead)
         Docs: man:bluetoothd(8)
    

    I have blueman, bluex, and bluez-utils installed. I don’t seem to find the bluetooth neiter in lspci nor in lsusb; their output, respectively:

    00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
    00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
    00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
    00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
    00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
    00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
    00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
    00:1c.1 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
    00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
    00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)
    00:1d.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #15 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
    01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
    02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
    04:00.0 Non-Volatile memory controller: Toshiba America Info Systems XG4 NVMe SSD Controller (rev 01)
    06:00.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
    07:00.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
    07:01.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
    07:02.0 PCI bridge: Intel Corporation DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]
    3e:00.0 USB controller: Intel Corporation DSL6340 USB 3.1 Controller [Alpine Ridge]
    
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 002: ID 2109:0100 VIA Labs, Inc. 
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 045e:07fd Microsoft Corp. Nano Transceiver 1.1
    Bus 001 Device 003: ID 1bcf:2b95 Sunplus Innovation Technology Inc. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    And this is what I get from rfkill list all

    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    

    I used to have the bluetooth in there up to yesterday.
    If I run

    sudo modprobe btsub
    sudo systemctl start bluetooth
    sudo systemctl enable bluetooth
    

    I get it to run:

    * bluetooth.service - Bluetooth service
       Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2018-08-22 13:17:07 CDT; 14s ago
         Docs: man:bluetoothd(8)
     Main PID: 4255 (bluetoothd)
       Status: "Running"
        Tasks: 1 (limit: 4915)
       Memory: 2.1M
       CGroup: /system.slice/bluetooth.service
               `-4255 /usr/lib/bluetooth/bluetoothd
    
    Aug 22 13:17:07 LX-Marco systemd[1]: Starting Bluetooth service...
    Aug 22 13:17:07 LX-Marco bluetoothd[4255]: Bluetooth daemon 5.50
    Aug 22 13:17:07 LX-Marco systemd[1]: Started Bluetooth service.
    Aug 22 13:17:07 LX-Marco bluetoothd[4255]: Starting SDP server
    Aug 22 13:17:07 LX-Marco bluetoothd[4255]: Bluetooth management interface 1.14 initialized
    

    but it still does not show up in rfkill list and bluetoothctl keeps saying No default controller available. Any suggesion would be really appreciated. Thanks.

  • @joekamprad thanks for your reply. I went yaourt bcm20702a1 and got:

    Packages (7) bcm20702a1-firmware-1201710-8  bcm20702b0-firmware-1201710-8  bcm20703a1-firmware-1201710-8  bcm43142a0-firmware-1201710-8
                 bcm4335c0-firmware-1201710-8  bcm4350c5-firmware-1201710-8  bcm4356a2-firmware-1201710-8
    
    Total Installed Size:  3.26 MiB
    
    :: Proceed with installation? [Y/n] 
    (7/7) checking keys in keyring                                                     [################################################] 100%
    (7/7) checking package integrity                                                   [################################################] 100%
    (7/7) loading package files                                                        [################################################] 100%
    (7/7) checking for file conflicts                                                  [################################################] 100%
    error: failed to commit transaction (conflicting files)
    bcm20702a1-firmware: /usr/lib/firmware/brcm/BCM20702A1-13d3-3404.hcd exists in filesystem
    bcm20703a1-firmware: /usr/lib/firmware/brcm/BCM-0a5c-6410.hcd exists in filesystem
    Errors occurred, no packages were upgraded.
    

    Am I missing something?

  • @lincoln_lee said in Bluetooth stopped working:

    bcm20702a1

    Download snapshot:

    https://aur.archlinux.org/packages/bcm20702a1-firmware/ ==>> Copy route ==>> and later for terminal:

    tar xf ...
    cd ....
    makepkg -si ....
    
  • @judd: thank you. I did that but I just get the same output as above. Do you think I should delete/move these files:

    bcm20702a1-firmware: /usr/lib/firmware/brcm/BCM20702A1-13d3-3404.hcd exists in filesystem
    bcm20703a1-firmware: /usr/lib/firmware/brcm/BCM-0a5c-6410.hcd exists in filesystem
    

    and retry?

  • @lincoln_lee said in Bluetooth stopped working:

    @judd: thank you. I did that but I just get the same output as above. Do you think I should delete/move these files:

    bcm20702a1-firmware: /usr/lib/firmware/brcm/BCM20702A1-13d3-3404.hcd exists in filesystem
    bcm20703a1-firmware: /usr/lib/firmware/brcm/BCM-0a5c-6410.hcd exists in filesystem
    

    and retry?

    Try to eliminate them, anything is reinstalled …

  • @judd said in Bluetooth stopped working:

    bcm20702a1

    They are firmware that are out of maintenance, since 2016 they are not updated … it’s weird this …

    https://github.com/search?q=bcm20702a1

  • @judd: I went for it but nothing is changed, back to square one.

    They are firmware that are out of maintenance, since 2016 they are not updated … it’s weird this …

    I really do not understand why they would stop working overnight, I don’t even recall making any update yesterday…

  • @lincoln_lee said in Bluetooth stopped working:

    Realmente no entiendo por qué dejarían de trabajar de la noche a la mañana, ni siquiera recuerdo haber hecho alguna actualización ayer …

    https://bbs.archlinux.org/viewtopic.php?id=226330

  • pacman -Q bluez
    

    ???

  • @judd: I have 5.50 indeed, must be the same problem as the guy here

    https://bbs.archlinux.org/viewtopic.php?id=226330

    I’ll downgrade to 5.47

  • @lincoln_lee said in Bluetooth stopped working:

    I’ll downgrade to 5.47

    It’s not a bad idea … it seems to me that the shots go there …

  • @judd Well, I tried both 5.49 and 5.47: no luck. None of them restores the functionality, unless there are other steps I shoult take after the downgrade…

  • You guys have any idea why I get bluetooth near rfkill in the lsmod list:

    → susudo lsmod | rg bluetooth            
    bluetooth             638976  11 btrtl,btintel,btbcm,bnep,btusb
    ecdh_generic           24576  1 bluetooth
    rfkill                 28672  7 bluetooth,dell_laptop,cfg80211
    crc16                  16384  2 bluetooth,ext4
    

    but not in the rfkill list itself?

    → rfkill list all
    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    
bluetooth55 stopped10 Posts 15Views 471
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.