• No WiFi or Wired internet for installation


    Hey everyone. I have a quick question about connecting to the internet for installation.

    I am currently running Arch Linux on my laptop, but want to reinstall with Antergos for a little bit more “complete” user experience. The problem that I’m having now is I can’t connect to the internet using WiFi on my laptop. I have no issues on my other Arch install. I have had the issue of no wired internet on my other Arch install, so that’s no surprising to me.

    I have done some troubleshooting over the past couple of hours. “journalctl -xn” tells me that the interface is already up and fails to connect. Taking the interface down then rerunning “netctl start Home” (Home is the name of the profile I’m starting). When that fails, journalctl returns “DHCP IPv4 lease attempt failed on interface wlp4s0”

    Lspci -k returns:
    04.00.0 Network controller: Qualcomm Antheros AR9287 Wireless Network Adaptor (PCI-Express) (rev 01)
    Subsystem: Foxconn International, Inc. Device e304
    Kernel driver in use: ath9k
    Kernel modules: ath9k
    05.00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Acer Incorporated [ALI] Device 0139
    Kernel modules: tg3

    I apologize for any misspellings, typing everything via mobile. If anyone wants or needs any other output, please let me know. Thanks!!!

  • Hey everyone. I have a quick question about connecting to the internet for installation.

    I am currently running Arch Linux on my laptop, but want to reinstall with Antergos for a little bit more “complete” user experience. The problem that I’m having now is I can’t connect to the internet using WiFi on my laptop. I have no issues on my other Arch install. I have had the issue of no wired internet on my other Arch install, so that’s no surprising to me.

    I have done some troubleshooting over the past couple of hours. “journalctl -xn” tells me that the interface is already up and fails to connect. Taking the interface down then rerunning “netctl start Home” (Home is the name of the profile I’m starting). When that fails, journalctl returns “DHCP IPv4 lease attempt failed on interface wlp4s0”

    Lspci -k returns:
    04.00.0 Network controller: Qualcomm Antheros AR9287 Wireless Network Adaptor (PCI-Express) (rev 01)
    Subsystem: Foxconn International, Inc. Device e304
    Kernel driver in use: ath9k
    Kernel modules: ath9k
    05.00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
    Subsystem: Acer Incorporated [ALI] Device 0139
    Kernel modules: tg3

    I apologize for any misspellings, typing everything via mobile. If anyone wants or needs any other output, please let me know. Thanks!!!

  • Hi,
    Have you tried connected to wireless from within System Settings>>Network?

    Running the following commands while your ethernet card is disabled (via System Settings>>Network) should result in it working properly once enabled again:

    su  
    modprobe -r tg3  
    modprobe broadcom  
    modprobe tg3
    

    Cheers!

  • When trying to connect via System Settings>>Network, the “working” animation is present for roughly 10-15 seconds, then it goes away. After running the commands that you listed, wired internet is now working, wireless is still an issue.

  • Problem solved! I got the wifi working after a fresh restart, entering the terminal and running

    ip link set wlp4s0 up
    

    then entering System Settings>>Network. Double clicked the network I wanted to connect to, then entered the password for the network. It took longer than I expected, but everything worked, and it’s connected to the network.

    I’ll update if I have any other issues.

    Thanks for your help! I appreciate it a bunch!

Posts 5Views 6366
Log in to reply