• spl install failling


    Hi,
    I have problem after last upgrade of kernel. I have zfs filesystem and when I try to run mkinitcpio -p linux it ends with error bcs failling instalation of spl kernel module (tried reinstall linux, linux-headers) and when i try to reinstall anything else at the end it wrote Fatal: kernel too old (maybe it could be helpful for diagnostic). Any suggestions how to solve this problem.
    Running KDE, curently 4.17.11-arch1, upgraded to 4.18.3-arch1
    Thank you

  • Whne I build module manually its ending on error:

    ==> dkms install spl/0.7.9 -k 4.18.3-arch1-1-ARCH
    Error! Bad return status for module build on kernel: 4.18.3-arch1-1-ARCH (x86_64)
    Consult /var/lib/dkms/spl/0.7.9/build/make.log for more information.
    

    and this is tail of make.log

      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-kobj.o
    /var/lib/dkms/spl/0.7.9/build/module/spl/spl-vnode.c: In function ‘vn_getattr’:
    /var/lib/dkms/spl/0.7.9/build/module/spl/spl-vnode.c:308:16: error: incompatible types when assigning to type ‘struct timespec’ from type ‘struct timespec64’
      vap->va_atime = stat.atime;
                    ^
    /var/lib/dkms/spl/0.7.9/build/module/spl/spl-vnode.c:309:16: error: incompatible types when assigning to type ‘struct timespec’ from type ‘struct timespec64’
      vap->va_mtime = stat.mtime;
                    ^
    /var/lib/dkms/spl/0.7.9/build/module/spl/spl-vnode.c:310:16: error: incompatible types when assigning to type ‘struct timespec’ from type ‘struct timespec64’
      vap->va_ctime = stat.ctime;
                    ^
    make[5]: *** [scripts/Makefile.build:317: /var/lib/dkms/spl/0.7.9/build/module/spl/spl-vnode.o] Error 1
    make[5]: *** Waiting for unfinished jobs....
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-atomic.o
    make[4]: *** [scripts/Makefile.build:558: /var/lib/dkms/spl/0.7.9/build/module/spl] Error 2
    make[4]: *** Waiting for unfinished jobs....
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-list.o
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-generic.o
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-cred.o
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-zlib.o
      CC [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat-linux.o
      LD [M]  /var/lib/dkms/spl/0.7.9/build/module/splat/splat.o
    make[3]: *** [Makefile:1500: _module_/var/lib/dkms/spl/0.7.9/build/module] Error 2
    make[3]: Leaving directory '/usr/lib/modules/4.18.3-arch1-1-ARCH/build'
    make[2]: *** [Makefile:11: modules] Error 2
    make[2]: Leaving directory '/var/lib/dkms/spl/0.7.9/build/module'
    make[1]: *** [Makefile:609: all-recursive] Error 1
    make[1]: Leaving directory '/var/lib/dkms/spl/0.7.9/build'
    make: *** [Makefile:490: all] Error 2
    
  • i am not using ZFS and so i do not call me an expert here ;)
    May there is a problem with current kernel version?
    https://github.com/zfsonlinux/zfs/releases

    I would try installing LTS kernel and see if you can build modules…

  • as @opoopo348 try out and report me over chat, SPL builds fine for LTS Kernel and system boots on ZFS … so seem to be still a problem with latest Kernel and ZFS.

    May @developers can have a little look into the issue?

  • 0_1534791448201_zfs.png
    hm does it work ?

  • Hi,

    I’ve found out that 0.7.9 isn’t expected to work on 4.18, 0.7.10 will when it gets released.

    We’ll have to wait…

    Reference:
    https://github.com/zfsonlinux/zfs/pull/7792
    https://github.com/zfsonlinux/zfs/issues/7785

  • as long as we wait LTS Kernel will work, on already installed systems… or could it work if i choose to install LTS Kernel on cnchi install?

  • @joekamprad said in spl install failling:

    could it work if i choose to install LTS Kernel on cnchi install?

    Hi,

    Maybe. Cnchi will set LTS as default (I have to check this, as I don’t remember if we finally implemented this or not).

  • @karasu
    Cnchi doesn’t install Linux-lts by default, I recently did a new install for someone and I didn’t see the LTS option in the option menu, so I also thought the LTS kernel was installedd by default, but it wasn’t.

  • @karasu
    Just installed Xfce a few minutes ago.

    LTS kernel is in the Cnchi options, but not selected by default. And not installed by default either.

  • @karasu said in spl install failling:

    Maybe. Cnchi will set LTS as default

    is what @karasu wanted to say, so if you choose to install LTS in advanced options it should boot automatic on LTS Kernel.

spl2 failling1 Posts 13Views 1098
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.