• Ugly fonts reading messages in Thunderbird since update to 60.0


    Everything was working fine in Thunderbird until the recent update to 60.0. Now when I open a message the fonts are sometimes very ugly – thin and washed out with occasional bold-looking appearance (for example the combinations “ti” and “tt” look almost bold face). It’s difficult to pin down exactly when the fonts are ugly, but sometimes messages look fine, sometimes the entire message is ugly, and sometimes only quoted previous messages are ugly. I’ve tried the following:

    • More→View Source: look for strange or specific encodings. Nothing unusual here, sometimes Content-Type: text/plain; charset=“utf-8” displays fine, sometimes it doesn’t. Couldn’t really find a correlation with charset.

    • Preferences→Display→ Fonts and Colors → Advanced: Check that legitimate fonts are chosen for the various options (serif, sans serif and monospace); tried switching to other fonts and that didn’t make a difference. Problem happens whether “Allow messages to use other fonts” is checked or not; some OK text reverts to the bad font when it is unchecked though.

    • On googling, I found this issue http://z-issue.com/wp/ugly-fonts-in-mozilla-firefox-and-thunderbird-under-linux-skia-and-cairo/ and had high hopes, but when I checked, my config file was already set to cairo.

    Any suggestions out there?

    • What is your DE?
    • Can you provide a screenshot?
  • Thanks for responding! Regarding my other post about registering for ArchLinux, yes this is what I was going to ask. I thought I’d try there, too. But anyway…

    • DE is XFCE.
    • Here’s screenshot of the bad font:

    0_1535218608925_92bb781e-a6d6-4153-b0d9-5b0a38d4d3b1-image.png

    And I should note, all updates available via Pacmac 6.4.0-1 have been applied.

  • i just play around with font settings inside thunderbird, and it seems like settings there do not change the fonts at all…

  • i do not have this screwed fonts:
    0_1535220164875_Bildschirmfoto vom 2018-08-25 20-02-04.png

  • So as i do not run XFCE it might be related to font setting inside XFCE settings?

  • Oh Oh Oh found the solution here!
    https://major.io/2017/08/02/thunderbird-changes-fonts-messages-not/

    Need to set fonts not only for Latin encoding, also for “Other writing systems”. I guess when Thunderbird gets a message that doesn’t have a language explicitly stated, it uses the settings for “Other writing systems”.

    Problem solved.

  • Good find!
    So it was Thunderbird itself, not a conflict between DE and the app.

    Great to see solving this, as I know it is very annoying to have ugly fonts.

  • More depth to the solution:
    The fix above allowed me to change fonts and get rid of the ugly one, but I discovered I had been using Calibri font, and when I switched back to Calibri, the ugliness returned. Then I remembered, when I first installed the system about two years ago I had added Calibri font so documents composed on Windows MS Word would look the same in LibreOffice. I had the same ugly font problem using Calibri in all applications and somehow found a solution which I didn’t remember.
    Turns out, as clearly described on the ArchWiki here, I could disable bitmap fonts for Calibri by adding
    <test qual=“any” name=“family”>
    <string>Calibri</string>
    </test>
    <edit name=“embeddedbitmap”>
    <bool>false</bool>
    </edit>
    to my ~/.config/fontconfig/fonts.conf file.
    Voila! No more ugly fonts, even with Calibri. The solution I found two years ago must have been something similar. Something must have happened to fontconfig in one of the many updates that happened around the time Thunderbird was upgraded to 60.0 in early August 2018. Still don’t know why only Thunderbird was affected, but all is good now.

fonts26 messages8 ugly3 reading2 Posts 9Views 892
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.