• removing hunspell-en breaks dependency : antergos-common-meta


    I ignore the updates too, the last time (a month ago) we had the same problem with hunspell-es and the Antergos devs came relatively fast with an update for the antergos-common-meta. So it’s just a matter of time untill this gets resolved. (it may take a bit longer now, it’s still summer holiday time)

  • With my solution no need to wait for any update. Just force remove hunspell-en and reinstall by -Syyu as antergos-common-meta dependency with all new packages.

  • Hi,

    antergos-common-meta 1.3 did not depend on hunspell… but sadly our build server is down so that update did not reach you.

    What I would do (as a workaround) is simply remove antergos-common-meta and then perform a full update:

    sudo pacman -R antergos-common-meta
    sudo pacman -Syu
    

    Cheers!

  • @karasu problen here is that if everyone is uninstalling antergos-common-meta they need to reinstall it later and most users will forget about it ;)

  • @dllmr , Same here. Did the same thing last night. Does seem to be the least risky solution for the time-being IMO.

  • @carlito , Yes un-checking definitely works. But afterwards better to put packages on the Ignore List, otherwise: your Pamac update notifier will remain “red” which is niggly even if all the other packages have been updated…! That’s my experience anyway 🙂

  • For those who have removed the antergos-common-meta, version 1.3 has arrived, so you can reinstall it again.

  • @bryanpwo
    Tried to install antergos-common-meta version 1.3. It conflicted with some files that I already had under /etc/skel/.config. But I just removed the old files and reinstalled antergos-common-meta.
    Let’s see how it works…

  • @bryanpwo
    OK, no issues other than that.

    Funny though that pamac-updater refused to install anything just because of those conflicting files. It could have asked if they can be replaced (and maybe show some diffs).

  • @manuel
    That’s strange indeed, I didn’t remove antergos-common-meta, so I really can’t back up your experience.

  • This works for me

    pacman -Rdd hunspell-en 
    pacman -Syyu
    
  • I saw the same problem too, but give my previous experience with Antergos I elected to wait for a few days, and today the update just worked!
    I would like to express my appreciation to the developers @karasu, @lots-0-logs, @Wyn10 and all the participants in this forum who make using Antergos a joy!
    And of course thanks should go to the Arch developers as well ( I choose to say that here rather than the Arch forums, as I’m not sure how the fact that I use Antergos would be accepted there.)

  • @blaised said in removing hunspell-en breaks dependency : antergos-common-meta:

    And of course thanks should go to the Arch developers as well ( I choose to say that here rather than the Arch forums, as I’m not sure how the fact that I use Antergos would be accepted there.)

    They can read your thankfull words here, even if they they do not support Antergos at the Archforum, i am sure there are some Archusers using Antergos Wiki and Forum to solve issues too ;)

  • In the new update, they’ve fixed the problem! :D

  • Hi all
    So I am confused ! Do we have a fix for this issue ?
    Here is what happens when I run pacman -Syu :
    Synchronizing package databases…
    antergos is up to date
    core is up to date
    extra is up to date
    community 4.5 MiB 4.13M/s 00:01 [######################] 100%
    multilib is up to date
    :: Starting full system upgrade…
    :: Replace hunspell-en with extra/hunspell-en_AU? [Y/n] n
    :: Replace hunspell-en with extra/hunspell-en_CA? [Y/n] n
    :: Replace hunspell-en with extra/hunspell-en_GB? [Y/n] n
    :: Replace hunspell-en with extra/hunspell-en_US? [Y/n] n
    :: Replace libx264 with extra/x264? [Y/n] n
    :: Replace libx264-all with extra/x264? [Y/n] n
    resolving dependencies…
    looking for conflicting packages…
    :: x264 and libx264 are in conflict. Remove libx264? [y/N] n
    error: unresolvable package conflicts detected
    error: failed to prepare transaction (conflicting dependencies)
    :: x264 and libx264 are in conflict

    Sorry I am not sure what to do here !
    Any help would be much appreciated !
    Thanks !

  • @pman6608 why you choose no?

  • Sorry but is it safe to choose yes for all ?

  • @pman6608 said in removing hunspell-en breaks dependency : antergos-common-meta:

    hunspell

    btw… the hunspell issue is solved and your one is related to a change in packages at Archmirrors…
    the two packages: libx264 and libx264-all are nited to only one package called: x264

    https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/x264&id=c2411345dd7a39390ce4019cea0bfbdd363feb1d

    https://www.reddit.com/r/archlinux/comments/97r0y2/libx264_vs_extrax264/

  • united…

  • I see ! OK thanks so much !

breaks38 dependency24 removing17 hunspell-en2 Posts 40Views 3778
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.