• removing hunspell-en breaks dependency : antergos-common-meta


    https://github.com/Antergos/antergos-packages/issues/372

    :: Replace hunspell-en with extra/hunspell-en_AU? [Y/n] Y
    :: Replace hunspell-en with extra/hunspell-en_CA? [Y/n] Y
    :: Replace hunspell-en with extra/hunspell-en_GB? [Y/n] Y
    :: Replace hunspell-en with extra/hunspell-en_US? [Y/n] Y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: removing hunspell-en breaks dependency 'hunspell-en' required by antergos-common-meta
    Error installing repo packages
    

    antergos-common-meta needs to be fixed … now it should hold:
    hunspell-en_AU hunspell-en_CA hunspell-en_GB hunspell-en_US instead of hunspell-en ?
    But it is not removed from repository …

    all of them are listed as dependencies of hunspell-en … https://www.archlinux.org/packages/extra/any/hunspell-en/
    But it have:

    Reverse Conflicts: hunspell-en_AU, hunspell-en_CA, hunspell-en_GB, hunspell-en_US

    I am clueless…

  • Okay, it’s not something stupid I did. I got this about an hour after a fresh install (18.8 iso) this afternoon. I wonder why it didn’t come up during the install? Maybe there’s a clue there.

  • @grenouille the hunspell update comes in after you do the initial install…

  • I’m getting the same problem right now too.

  • @joekamprad

    Ah, okay. Thanks for that. Guess today is not a total waste as I, once again, learned something here.

  • if you want to do the update you will need to uninstall antergos-common-meta till it will be fixed by developers

  • I am getting the hunspell-en problem also.

    In addition, Nautilus (Files) is messed up and even in a terminal, the ls command is not working properly.

    Not sure if the two are related, just throwing that out there as maybe a possible clue.

  • The problem is that if I remove antergos-common-meta it removes a LOT of other packages, basically the entire desktop. Curios it happened to me only in KDE but not with GNOME.

  • Hello all just confirming I too have the same issue when trying to
    update ! For now I answered no to everything and did not update anything
    pending a fix !

  • I’m having this issue also.

  • same problem

  • Not sure if this is related but http://status.antergos.com/build.antergos.com” is also having a service disruption. Just as my two cents love this community to death but between antergos’ lightdm bugging out every other time I use it and the antergos packages messing up my updates if I remove these things I basically get…Arch. No offence to the devs just wish I knew how to help. :/

  • @linuxhelmet

    Well Antergos is just an Arch installer at the end of the day…

    As for this issue I can confirm. Unable to update, just going to wait for the devs to fix compatibility issues as adding hunspell-en to my ignored packages didn’t fix much, because then hunspell-en_GB and the rest conflict with hunspell-en.

  • same here on gnome

  • @cortez-khristian said in removing hunspell-en breaks dependency : antergos-common-meta:

    The problem is that if I remove antergos-common-meta it removes a LOT of other packages, basically the entire desktop. Curios it happened to me only in KDE but not with GNOME.

    I can’t tell you exactly what to do because it all depends on what your system has

    but a piece of advise rather than waiting for the other devs to do what they have to do

    the only package that I know of that it would remove a lot of packages is hunspell by itself and nothing else … anyone that would say otherwise is making it up

    a workaround would be to first IgnorePkg before updating, then remove hunspell-en and then to select the extra/hunspell-en_* again

  • Same issue here on openbox

  • same on cinnamon [dont think its de related]

  • If on pamac, has anyone tried to uncheck the hunspell-en_* (on hold) packages (whatever these are) and then go ahead with the updates, and then remove hunspell-en? Then go back and reselect the hunspell-en_* packages?

  • This work for me:

    pacman -Rdd hunspell-en && pacman -Syyu
    
  • My workaround, fwiw:
    0_1534490278779_t.jpg

breaks38 dependency24 removing17 hunspell-en2 Posts 40Views 3781
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.