• keyboard layout on login


    I have my keyboard layout set to Dvorak, but on the login screen the keyboard is the standard US one. How do I change the keyboard layout on the login screen?

    I’m using XFCE with lightdm.

  • @manuel
    /etc/X11/xorg.conf.d/00-keyboard.conf already exists and it contains the following:

    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "us"
            Option "XkbModel" "dvorak"
    EndSection
    
  • @notxarb Actually I noticed I have the same issue. :)
    So far it has not been a problem for me, but now I’ll start finding out a fix. So far I have nothing, but as soon as I find something, I’ll keep you posted!

  • it seems that keyboard settings are possible with lightdm config files, but it do not work at all… it should have a switcher possible also but it do not show up…

    i do not test it but somme timne ago @lots-0-logs posted this solution:

    You can add the command to /etc/lightdm/lightdm.conf as the value of the following configuration option:

    #greeter-setup-script=
    

    Be sure to remove the # symbol from the front of the line so that it looks like this:

    greeter-setup-script=/usr/bin/setxkbmap lang_code
    

    and replace lang_code with the one you need

    something like:

    /usr/bin/setxkbmap -layout us,us -variant ,dvorak

  • @notxarb
    Hi,
    I have US keyboard layout at the login screen right after booting into it.
    But when I start writing the password, the keyboard indicator magically changes to the language I’m using.

    I’m not sure how it happened, but now I unticked Settings -> Keyboard -> Layout -> Use system defaults. Then I added the correct keyboard layout from the Keyboard layout part of the same window, and set it the first one.

    Maybe a reboot is needed after those settings, not sure though.

  • Oh, I’m using SDDM, not lightdm, so this maybe doesn’t help you, but shouldn’t hurt either.

  • @joekamprad that doesn’t seem to have helped. 🙁 Maybe the lang_code is wrong? Where do I find the correct lang_code?

    @manuel I already have my settings like that.

    Thanks for your help guys!

login131 keyboard75 layout15 Posts 9Views 429
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.