• liblastfm broken?


    Hi,

    is liblastfm-qt5 (1.1.0.r637-4) from the Antergos repo currently broken?
    I wanted to start amarok, however I get the following error:
    amarok: error while loading shared libraries: liblastfm.so.1: cannot open shared object file: No such file or directory
    I can not easily switch to the Arch repo version because the Antergos repo version seems newer.
    I also can not use any other music player which needs liblastfm like clementine

  • @got-it-man
    It doesn’t seem to work with liblastfm-qt5, but works with liblastfm-qt4. When amarok is installed, it lets you choose between these two libs.

    @developers might want to know about this issue.

  • Still no one looking into this?
    It would be great to be able to use other music players like VLC and MPV.

  • @got-it-man said in liblastfm broken?:

    It would be great to be able to use other music players like VLC and MPV.

    They are working fine here, i have liblastfm-qt4 from extra repository.

  • @got-it-man

    @developers already working on this:

    https://github.com/Antergos/antergos-packages/commit/4b08fbc206eae4cf9605c249ce18cfd0d20b199c

    Current workaround is to choose liblastfm-qt4 on initial install of amarok or clementine (or any other depending on liblastfm-qt)

    liblastfm-qt5 should be removed from repository, and will soon, but needs confirmation of responsible devs first.

    If you already have it installed and you have choosen liblastfm-qt5 simple change to the other version:

    sudo pacman -S liblastfm-qt4
    
broken38 liblastfm1 Posts 5Views 316
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.