• Namensauflösung funktioniert nicht


    Hallo Freunde! Mein letztes Problem (Re: Nur Google geht noch / Server-Ip-Adresse nicht gefunden) war nicht reproduzierbar und verschwand von Geisterhand, deswegen fehlt mir dort der Lösungansatz. Das neue Problem ist ähnlich gelagert, aber leider dauerhaft: die Namensauflösung funktioniert nicht!
    Konkret: „8.8.8.8“ anpingen geht, bei „www.google.de“ sagt’s „ping: www.google.de: Der Name oder der Dienst ist nicht bekannt“.

    Die meisten Lösungswege, die ich so ergoogeln konnte, beziehen sich aber auf die Situation, wo selbst pingen nicht geht, und/oder Arch.

    Vielleicht ist es noch erwähnenswert, dass das Problem „völlig aus dem Nichts“ kam. Habe neben opera noch FF gestartet, der konnte keine Seiten mehr aufbauen (DNS Fehler), opera ging weiterhin. Nach einem Neustart ging dann gar kein Browser mehr :(

    Vielen Dank für eure Gedanken im Voraus!

  • @tivi said in Namensauflösung funktioniert nicht:

    ping www.google.de

    ping google.de
    

    müsste reichen ;)

    hattest damals die Frage ob die Gufw Firewall installiert ist und eventuell das Problem verursacht.
    DIe andere Frage ist ob du irgendetwas an den DNS/Netzwerkeinstellungen auf dem Antergos System gändert angepasst hast

  • War ja klar, dass du wieder als erstes antwortest :)

    Gufw habe ich installiert, aber ausschalten bringt nichts.
    Sowohl „google.com“ als auch „www.google.com“ anpingen gibt die gleiche Fehlermeldung aus.

  • Kann auch ein Problem mit dem Treiber/Firmware für die Netzwerkkarte sein… aber ohne inet schwer das Journal zu teilen…

  • hast du versucht ipv6 zu deaktivieren?

  • @joekamprad said in Namensauflösung funktioniert nicht:

    hast du versucht ipv6 zu deaktivieren?

    Ist in der Fritzbox deaktiviert (auf die habe ich per ip noch Zugriff, bei anderen Websites scheitert auch die manuelle ip-Eingabe).

    Ich könnte das Journal mit Umwegen über usb-stick und dual boot mit Windows hochladen (dann hätte Windows dieses Jahr sogar noch einen Nutzen :) ), muss dafür aber erst zuhause ankommen. Werd es später mal probieren.

    Welche konkreten logs wären denn relevant? In der Hinsicht habe ich das Gefühl, noch gar nichts gelernt zu haben :(

  • lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt
    

    würde gut sein, dann kannst du log.txt auf einen stick kopieren.

    Mit IPV6 deaktivieren meine ich in deiner Antergos installation, ist im network-manager standardmäßig aktiviert, kann aber probleme verursachen wenn router/provider/DNS-Server da Probleme verursachen…

  • So, nun endlich mal nicht vom Handy.
    IPV6 ist auch im NetworkManager deaktiviert.
    Das mit der Log-Datei hat etwas gedauert, da Windows die Formatierung nicht so richtig einsehen wollte.
    https://workupload.com/file/2YKHCBM
    Passwort: fuerjoe

    Danke :)

  • Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.5720] ovsdb: Verbindung ist gescheitert: Datei oder Verzeichnis nicht gefunden
    Aug 12 16:13:13 pc1 dbus-daemon[379]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service' requested by ':1.8' (uid=0 pid=382 comm="/usr/bin/NetworkManager --no-daemon ")
    Aug 12 16:13:13 pc1 nm-dispatcher[473]: req:2 'connectivity-change': new request (0 scripts)
    Aug 12 16:13:13 pc1 nm-dispatcher[473]: req:2 'connectivity-change': completed: no scripts
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.5748] bluez: use BlueZ version 5
    Aug 12 16:13:13 pc1 systemd[1]: Starting WPA supplicant...
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.5784] modem-manager: ModemManager available
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.5798] bluez5: NAP: added interface C4:85:08:42:04:5E
    Aug 12 16:13:13 pc1 mysqld[477]: 2018-08-12 16:13:13 139708210233280 [Note] /usr/bin/mysqld: ready for connections.
    Aug 12 16:13:13 pc1 mysqld[477]: Version: '10.1.34-MariaDB'  socket: '/run/mysqld/mysqld.sock'  port: 3306  MariaDB Server
    Aug 12 16:13:13 pc1 dbus-daemon[379]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
    Aug 12 16:13:13 pc1 systemd[1]: Started WPA supplicant.
    Aug 12 16:13:13 pc1 wpa_supplicant[521]: Successfully initialized wpa_supplicant
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.6014] supplicant: wpa_supplicant running
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.6014] device (wlp2s0): supplicant interface state: init -> starting
    Aug 12 16:13:13 pc1 systemd[1]: Started MariaDB 10.1.34 database server.
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.6454] sup-iface[0x55f351047220,wlp2s0]: supports 5 scan SSIDs
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.6465] device (wlp2s0): supplicant interface state: starting -> ready
    Aug 12 16:13:13 pc1 NetworkManager[382]: <info>  [1534083193.6465] device (wlp2s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
    Aug 12 16:13:16 pc1 NetworkManager[382]: <info>  [1534083196.8662] policy: auto-activating connection 'FRITZ!HORST!Box 6490 Cable2,4' (d93848a5-9b3d-4db3-9c22-1d7d77b18fea)
    Aug 12 16:13:16 pc1 NetworkManager[382]: <info>  [1534083196.8671] device (wlp2s0): Activation: starting connection 'FRITZ!HORST!Box 6490 Cable2,4' (d93848a5-9b3d-4db3-9c22-1d7d77b18fea)
    Aug 12 16:13:16 pc1 NetworkManager[382]: <info>  [1534083196.8673] device (wlp2s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:16 pc1 NetworkManager[382]: <info>  [1534083196.8678] manager: NetworkManager state is now CONNECTING
    Aug 12 16:13:16 pc1 NetworkManager[382]: <info>  [1534083196.8825] device (wlp2s0): set-hw-addr: reset MAC address to C4:85:08:42:04:5A (preserve)
    Aug 12 16:13:16 pc1 kernel: iwlwifi 0000:02:00.0: Radio type=0x2-0x1-0x0
    Aug 12 16:13:17 pc1 colord[432]: failed to get session [pid 484]: Keine Daten verf\FCgbar
    Aug 12 16:13:17 pc1 colord[432]: CdMain: failed to read /proc/484/cmdline
    Aug 12 16:13:17 pc1 kernel: iwlwifi 0000:02:00.0: Radio type=0x2-0x1-0x0
    Aug 12 16:13:17 pc1 kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2820] device (wlp2s0): supplicant interface state: ready -> disabled
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2824] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2829] device (wlp2s0): Activation: (wifi) access point 'FRITZ!HORST!Box 6490 Cable2,4' has security, but secrets are required.
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2829] device (wlp2s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2832] sup-iface[0x55f351047220,wlp2s0]: wps: type pbc start...
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2860] device (wlp2s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2867] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2871] device (wlp2s0): Activation: (wifi) connection 'FRITZ!HORST!Box 6490 Cable2,4' has security, and secrets exist.  No new secrets needed.
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2871] Config: added 'ssid' value 'FRITZ!HORST!Box 6490 Cable2,4'
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2872] Config: added 'scan_ssid' value '1'
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2872] Config: added 'bgscan' value 'simple:30:-80:86400'
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2872] Config: added 'key_mgmt' value 'WPA-PSK'
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.2872] Config: added 'psk' value '<hidden>'
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.3184] device (wlp2s0): supplicant interface state: disabled -> inactive
    Aug 12 16:13:17 pc1 NetworkManager[382]: <info>  [1534083197.3313] device (wlp2s0): supplicant interface state: inactive -> scanning
    Aug 12 16:13:20 pc1 wpa_supplicant[521]: wlp2s0: SME: Trying to authenticate with cc:ce:1e:a9:9d:57 (SSID='FRITZ!HORST!Box 6490 Cable2,4' freq=2412 MHz)
    Aug 12 16:13:20 pc1 kernel: wlp2s0: authenticate with cc:ce:1e:a9:9d:57
    Aug 12 16:13:20 pc1 NetworkManager[382]: <info>  [1534083200.5394] device (wlp2s0): supplicant interface state: scanning -> authenticating
    Aug 12 16:13:20 pc1 kernel: wlp2s0: send auth to cc:ce:1e:a9:9d:57 (try 1/3)
    Aug 12 16:13:20 pc1 wpa_supplicant[521]: wlp2s0: Trying to associate with cc:ce:1e:a9:9d:57 (SSID='FRITZ!HORST!Box 6490 Cable2,4' freq=2412 MHz)
    Aug 12 16:13:20 pc1 kernel: wlp2s0: authenticated
    Aug 12 16:13:20 pc1 kernel: wlp2s0: waiting for beacon from cc:ce:1e:a9:9d:57
    Aug 12 16:13:20 pc1 NetworkManager[382]: <info>  [1534083200.5478] device (wlp2s0): supplicant interface state: authenticating -> associating
    Aug 12 16:13:20 pc1 kernel: wlp2s0: associate with cc:ce:1e:a9:9d:57 (try 1/3)
    Aug 12 16:13:20 pc1 kernel: wlp2s0: RX AssocResp from cc:ce:1e:a9:9d:57 (capab=0x431 status=0 aid=2)
    Aug 12 16:13:20 pc1 wpa_supplicant[521]: wlp2s0: Associated with cc:ce:1e:a9:9d:57
    Aug 12 16:13:20 pc1 wpa_supplicant[521]: wlp2s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
    Aug 12 16:13:20 pc1 wpa_supplicant[521]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=DE
    Aug 12 16:13:20 pc1 kernel: wlp2s0: associated
    Aug 12 16:13:20 pc1 NetworkManager[382]: <info>  [1534083200.5942] device (wlp2s0): supplicant interface state: associating -> associated
    Aug 12 16:13:21 pc1 wpa_supplicant[521]: wlp2s0: WPA: Key negotiation completed with cc:ce:1e:a9:9d:57 [PTK=CCMP GTK=CCMP]
    Aug 12 16:13:21 pc1 wpa_supplicant[521]: wlp2s0: CTRL-EVENT-CONNECTED - Connection to cc:ce:1e:a9:9d:57 completed [id=0 id_str=]
    Aug 12 16:13:21 pc1 systemd-networkd[345]: wlp2s0: Gained carrier
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.5896] device (wlp2s0): supplicant interface state: associated -> completed
    Aug 12 16:13:21 pc1 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.5897] device (wlp2s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'FRITZ!HORST!Box 6490 Cable2,4'.
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.5899] device (wlp2s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.5905] dhcp4 (wlp2s0): activation: beginning transaction (timeout in 45 seconds)
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6204] dhcp4 (wlp2s0):   address 192.168.178.28
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6204] dhcp4 (wlp2s0):   plen 24
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6205] dhcp4 (wlp2s0):   expires in 864000 seconds
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6205] dhcp4 (wlp2s0):   nameserver '192.168.178.1'
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6205] dhcp4 (wlp2s0):   domain name 'fritz.box'
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6205] dhcp4 (wlp2s0):   gateway 192.168.178.1
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6206] dhcp4 (wlp2s0):   ntp server '192.168.178.1'
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6209] dhcp4 (wlp2s0): state changed unknown -> bound
    Aug 12 16:13:21 pc1 avahi-daemon[378]: Joining mDNS multicast group on interface wlp2s0.IPv4 with address 192.168.178.28.
    Aug 12 16:13:21 pc1 avahi-daemon[378]: New relevant interface wlp2s0.IPv4 for mDNS.
    Aug 12 16:13:21 pc1 systemd-timesyncd[346]: Network configuration changed, trying to establish connection.
    Aug 12 16:13:21 pc1 avahi-daemon[378]: Registering new address record for 192.168.178.28 on wlp2s0.IPv4.
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6239] device (wlp2s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6262] device (wlp2s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6269] device (wlp2s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6277] manager: NetworkManager state is now CONNECTED_LOCAL
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6403] manager: NetworkManager state is now CONNECTED_SITE
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6405] policy: set 'FRITZ!HORST!Box 6490 Cable2,4' (wlp2s0) as default for IPv4 routing and DNS
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6489] device (wlp2s0): Activation: successful, device activated.
    Aug 12 16:13:21 pc1 NetworkManager[382]: <info>  [1534083201.6497] manager: startup complete
    Aug 12 16:13:21 pc1 nm-dispatcher[473]: req:3 'up' [wlp2s0]: new request (0 scripts)
    Aug 12 16:13:21 pc1 nm-dispatcher[473]: req:3 'up' [wlp2s0]: completed: no scripts
    Aug 12 16:13:21 pc1 wpa_supplicant[521]: wlp2s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-59 noise=9999 txrate=1000
    Aug 12 16:13:23 pc1 avahi-daemon[378]: Joining mDNS multicast group on interface wlp2s0.IPv6 with address fe80::c685:8ff:fe42:45a.
    Aug 12 16:13:23 pc1 systemd-networkd[345]: wlp2s0: Gained IPv6LL
    Aug 12 16:13:23 pc1 avahi-daemon[378]: New relevant interface wlp2s0.IPv6 for mDNS.
    

    Hm also Wlan? oder Kabelgebunden ?

  • Habe beides versucht, gleicher Fehler. Momentan (und während des logs) ist er per WLAN verbunden.

  • @joekamprad said in Namensauflösung funktioniert nicht:

    state change: unavailable -> disconnected (reason ‘supplicant-available’, sys-iface-state: ‘managed’)

    Für mich sieht das eher nach einem problem mit network-manager aus… aber so vielsagend ist der ouput nicht:

    systemctl status NetworkManager.service
    

    könnte etwas ausgeben…

  • Das ergibt Folgendes:

    ● NetworkManager.service - Network Manager
       Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
      Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
               └─NetworkManager-ovs.conf
       Active: active (running) since Sun 2018-08-12 19:05:03 CEST; 1min 22s ago
         Docs: man:NetworkManager(8)
     Main PID: 388 (NetworkManager)
        Tasks: 3 (limit: 4374)
       Memory: 16.2M
       CGroup: /system.slice/NetworkManager.service
               └─388 /usr/bin/NetworkManager --no-daemon
    
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1413] dhcp4 (wlp2s0):   ntp server '192.168.178.1'
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1417] dhcp4 (wlp2s0): state changed unknown -> bound
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1456] device (wlp2s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1475] device (wlp2s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1497] device (wlp2s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1503] manager: NetworkManager state is now CONNECTED_LOCAL
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1652] manager: NetworkManager state is now CONNECTED_SITE
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1655] policy: set 'FRITZ!HORST!Box 6490 Cable2,4' (wlp2s0) as default for IPv4 routing and DNS
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1736] device (wlp2s0): Activation: successful, device activated.
    Aug 12 19:05:13 pc1 NetworkManager[388]: <info>  [1534093513.1752] manager: startup complete
    
    
    
  • @tivi

    policy: set 'FRITZ!HORST!Box 6490 Cable2,4' (wlp2s0) as default for IPv4 routing and DNS
    

    also nur ipv4… und es fehlt nameserver sowas wie:

    dhcp4 (wlp2s0):   nameserver 192.168.178.1
    

    Ich habe aber keine Ahnung was da schief läuft…

  • Oh wenn du schon überfragt bist, dann kann ich es ja gleich neu installieren 🙈

  • andersherum probieren, IPv4 deaktivieren und nur IPv6 nehmen… (natürlich im Router IPv6 wieder aktivieren falls noch nicht getan)

  • Fehler besteht weiterhin.
    Ich weiß nicht ob es relevant ist, aber IPv6 wird bei uns nur über ein Tunnelprotokoll bereitgestellt.

connection32 dns5 ping5 namensauflösung1 Posts 17Views 399
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.