• System Language got changed after installing Ibus?

    I am using the latest antergos with Cinnamon DE. I also have deepin installed (but I rarely use it)

    I am from India so I installed Ibus and the m17 database to type using my regional language Tamil. I am able to swap my keyboard layout between English to Tamil by using Super+Space key (As defined in the Ibus preferences).

    Ever since I installed that I am starting to have this problem. I think my system language has been changed to another regional language Malayalam.
    In cinnamon I noticed the menu interface language of VLC media player is changed from English to Malayalam.

    I thought that only VLC’s language got changed. But when I opened my Notepadqq, there also the language got changed from English to Malayalam.
    Please note that only few applications are displaying menu interface language as Malayalam. My cinnamon start menu, and other applications like Firefox, Darktable, Pacman, etc are still having English as menu language.

    I think VLC and Notepadqq are taking the menu option language from system language (which is changed to Malayalam, I suppose)

    I am not able to find the system language settings anywhere. Can you please tell me how do I reset the system language to English-US?

    Note: When I logged into Deepin, I am not able to see any English . All that I could see is only Malayalam. I mean, the DE language itself is not English.

  • what is giving you the command:


    You can set locale manually as written here:


  • @joekamprad Thank you for the reply. This is what I am getting when I run the command localectl

    System Locale: LANG=en_US.UTF-8
        VC Keymap: us
       X11 Layout: us

    Looks like the issue is not with the system language? What did I miss? Why am I getting some other language in VLC media player and Notepadqq?

    Looklbolded text

  • @0liyan said in System Language got changed after installing Ibus?:
    Cinnamon DE = gtk
    vlc = qt
    Notepadqq = qt

    is what i can give you… but i do not know about that qt apps having other language settings, then DE… may qt5ct font settings are wrong?

  • @joekamprad Yes, you’re right. The QT font settings are wrong. I just noticed that in my QT assistant. Note that I also installed the ibus-qt package. I don’t know whether it is something that I did to corrupt the qt font settings or the ibus-qt corrupted it.

    Anyhow, can you please tell me how to reset the QT interface language?

  • Inside the qt5ct tool are only font and style settings… And I am away from call me knowledged about it 😑

  • Do you check settings inside deepin DE already? As it uses lot a qt stuff.

  • @joekamprad I am not able to navigate in Deepin DE as the language has been changed to Malayalam (which I don’t understand). But as far as I remember, I didn’t change any settings in Deepin DE.

  • i would bet on DEEPIN is the culprit then…

    If you do not mind reset deepin by moving the configs out of the way:

    mv ~/.config/dconf/user ~/.config/dconf/backup.user and then login to deepin

  • @joekamprad I simply copied and ran the above command. I logged into Deepin. But I still see it in Malayalam. It didn’t helped.

    On the other hand, I wanna uninstall Deepin completely from my system as I don’t use it. I guess that could solve the issue? Could you please tell me how to completely remove the Deepin DE from Antergos?

  • should work with:

    sudo pacman -Rcns antergos-deepin-meta

    if you want go sure reinstall cinnamon after the removal:

    sudo pacman -S antergos-cinnamon-meta antergos-common-meta

    And you can remove all related settings for deepin and qt also:

    mkdir ~/configbackups
    mv ~/.config/deepin ~/configbackups/
    mv ~/.config/qt5ct ~/configbackups/
    mv ~/.config/kdeglobals ~/configbackups/
    mv ~/.config/Trolltech.conf ~/configbackups/
  • @joekamprad THAT WORKED! Thank you so much.
    Looks like I messed up something with qt. This is what I did.

    Actually I was unable to run the below command.
    sudo pacman -Rcns antergos-deepin-meta
    I got target not found error.

    But I went ahead and moved the configuration settings into a new folder as you’ve mentioned. Logged back into Deepin and the language was back to English.
    Similarly my VLC and Notepadqq are also in English now.

    Somewhere in this forum, I happened to see the below command
    sudo -Runs deepin
    which completely removed the Deepin from my system.

  • @0liyan said in System Language got changed after installing Ibus?:

    sudo -Runs deepin

    sudo pacman -Runs deepin
system141 installing125 language33 changed5 Posts 13Views 468
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.