• Perl problem with pamac


    Hi,

    Every time I try to update Perl I get a dependency issue.

    could not satisfy dependencies:
    installing perl (5.28.0-1) breaks dependency ‘perl<5.27’ required by hivex
    installing perl (5.28.0-1) breaks dependency ‘perl<5.27’ required by perl-gtk2-unique
    installing perl (5.28.0-1) breaks dependency ‘perl<5.27’ required by perl-sys-virt

    even if I un-select it, it wont allow updates to continue.

    Anyone else having this issue?

  • @brianhedley798
    Two (hivex and perl-sys-virt) of those three AUR packages are already outdated. It may be hard to find any support for them (but you can check their AUR pages of course), so you may need to find alternative packages for (all of) them.

    So first thing to do is try to uninstall those three packages:

    sudo pacman -Rsn hivex perl-gtk2-unique perl-sys-virt
    

    then try update again.

  • this last update was HUGE and broke many things. i was using shutter from aur and had to uninstall it along with the packages pamac complained about. in your case you’ll need to remove

    hivex
    perl-gtk2-unique
    perl-sys-virt
    

    anything depending on perl from aur hopefully will be updated to use the new perl. this is getting ridiculous every perl update all perls from aur break

pamac65 perl2 Posts 3Views 1549
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.