• Need emergency help, severe problems logging in!

    So Saturday morning, I ripped Mint 18 off my Plex media server setup and installed a fresh copy of Antergos with the Cinnamon desktop.

    I got everything installed and working perfectly. Had a few stumbling blocks but all in all, not to bad. Saturday night, I had MDADM do a scrub of my RAID 5 array. It took about 12 hours but no errors reported. Sunday night, I kicked off a scrub of my RAID 6 array (neither of these arrays are boot drives… I have an SSD for my boot drive and the RAID arrays are just data… but remember this 2nd array scrub, it will come up later in my story).

    So over the weekend, I did a couple reboots to test things out and everything was going like clockwork. Applied some updates, installed TeamViewer, all systems go!

    When I got up this morning, I wanted to use TeamViewer to connect from a Windows box upstairs into Antergos to check on the progress of the MDADM scrub of the RAID 6 array. I connected via TV, typed my password to unlock the screen and opened a terminal, elevated my access and checked the status. It had about 2.5 hours left to go. I locked the screen and disconnected TV.

    Then, I noticed that on this same Windows PC, it gave me an error about how the backup program couldn’t find ‘server-pc’ on the network. Then I remembered, when I installed Antergos, I set the hostname as ‘antergos-server’. I thought, no biggie, I’ll just use TeamViewer and connect to the Antergos box in the basement and correct that real quick.

    I connected via TeamViewer, typed my password at the lock screen and got logged in with no problem. I opened a terminal and elevated my access and edited /etc/hostname and erased ‘antergos-server’ and typed ‘server-pc’ and saved the file and exited out of the editor.

    I disconnected TeamViewer.

    The PC STILL had problems seeing ‘server-pc’ then I remembered, I could just type ‘hostname server-pc’ to change it immediately (I couldn’t reboot because the scrub was still going).

    Back to TeamViewer. I logged in and carried out the command and Antergos instantly switched the hostname to ‘server-pc’. I locked the screen then logged out of TeamViewer.

    I didn’t bothered checking the Windows box if the backup program was happy now and was able to see ‘server-pc’ and back up it’s files so I moved on to something else. Breakfast.

    After breakfast and right before needing to leave for work, I launched TV again as I wanted to check the status of the scrub. But this time, it got stuck at something like “initializing display”… or something along those lines. No biggie, TV has done this to me before with Mint so I closed it and re-opened it and tried connecting to the Antergos box again. Same problem.

    I walked downstairs and jiggled the mouse to wake up the monitor. The lock screen came up. I typed my password (I could see the asterisks popping up) and hit enter and nothing happened. No error about wrong password, screen didn’t unlock, it just sat there.

    Perplexed, I clicked on ‘Switch user’. This brought me to another login screen and I typed my password there and THEN the screen unlocked. I thought I was out of the woods but I quickly realized that nothing was launching. I clicked the terminal shortcut and I get a spinning wheel for a bit then back to mouse cursor. Clicking on the Chromium browser shortcut, same thing. Clicking on the “start” button, nothing comes up.

    I don’t think the box is locked up or crashed because I was able to verify Plex is still running when I logged in to plex.tv from another computer.

    What in the world did I do? Could changing that hostname be responsible for all this? Unfortunately, I don’t think SSH is running because when I tried SSH’ing into it, I got a ‘connection refused’ error.

    I didn’t want to just force the computer off via the power button because the MDADM scrub is still running. Even if I could force a reboot, will it come back up and be in this same state?

    I have a UPS hooked up to it and I did configure that to shutdown once the battery level is critical but with Arch being Arch… when I installed the APC-UPS program, I’m not sure if there was some SystemD service I needed to activate to get that working!?

    So on a scale of 1 to 10, how screwed am I? :(

    I’m stuck at work for the next 6 hours but would greatly appreciate any and all offers of assistance!

  • Quick update… I was able to hit ALT-F1? or CTRL-ALT-F1? and open up another console. I logged in as root, verified the scrub was finished and issued the ‘reboot’ command and all is well in the universe. TeamViewer was acting REALLY odd when I installed it. Lots of flashing screens when I moved my mouse. Maybe TeamViewer captured keyboard input when it hung as I tried logging in that one time? In any case, Antergos is rocking along nice and steady.

    I’m going to remove TeamVIewer and switch to some VNC type of client for remote desktop. I also enabled SSH. :)

  • @roadhazard
    SSH is the traditional Linux way of doing things remotely.
    I’ve not much experience with TeamViewer, I’ve heard good things about it, but it seems rather heavy stuff compared to SSH …

logging7 emergency4 severe1 Posts 3Views 224
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.