• Current aurman release from Antergos repo broken


    Hi,

    it looks like due to recent Python updates there’s a problem with aurman. You can not use aurman anymore and get errors if you start aurman.

    Related: https://github.com/polygamma/aurman/issues/239
    The problem got fixed for the package from the AUR, however not the version from the repo of antergos.

    Looks like aurman from the Antergos repo is still on version 2.16.10-1.
    Please update aurman from the Antergos repo.

    As a workaround it’s possible to install aurman from the AUR with yaourt.
    yaourt -S aur/aurman

  • Error from aurman (Antergos)

    Traceback (most recent call last):
      File "/usr/bin/aurman", line 6, in <module>
        from pkg_resources import load_entry_point
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3095, in <module>
        @_call_aside
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3079, in _call_aside
        f(*args, **kwargs)
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set
        working_set = WorkingSet._build_master()
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 570, in _build_master
        ws.require(__requires__)
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 888, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 774, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'aurman==2.16.10' distribution was not found and is required by the application
    
    
  • i just build the latest version here, if you do not want to wait for it…

    http://kamprad.net/Downloads/aurman-2.17.1-1-any.pkg.tar

  • Done!

    Thanks for the warning.

repo17 release8 current7 aurman3 Posts 6Views 542
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.