• Dell XPS 13 (9360) : Screen brightness control stopped working


    Is someone else facing a similar issue of not able to adjust the screen brightness ? Both brightness control in Gnome GUI and Fn keys have stopped working. I am able to change the brightness by changing values manually in /cd /sys/class/backlight/intel_backlight/brightness. It used to work perfectly fine ever since fresh install (3 weeks back) till it stopped now.

    I recently upgraded all the packages which included a move to Kernel 4.17.11-arch1 and linux-firmware 20180717.8d69bab-1. I noticed the error after the upgrade.

  • @vishnuedamana
    Have you tried booting to linux-lts? It can be installed with command

    sudo pacman -S linux-lts
    
  • @manuel Thanks for the reply !

    I tried rolling back to 4.17.9 a-1, as I didn’t have issues with the previous setup, but it didn’t work. As you suggested I downgraded to LTS kernel and appropriate linux-headers; used downgrade utility for it and then upgraded the grub. Still the issue remains.
    Here is the dmesg out as you suggest 😉

  • @easwaran
    I actually suggest doing kernel installation the official way:

    sudo pacman -S linux-lts
    

    and optionally linux-lts-headers if needed. This way you’ll have e.g. initramfs handled properly (I’m not sure if downgrade does it).

    Anyway, since downgrading to previously working kernel didn’t work anymore, then I guess it cannot be a kernel issue. I suspect Gnome, although I have no proof of it. ;)

    Depending on your machine, you could try installing package xorg-xbacklight and check if command xbacklight works. See

    man xbacklight
    

    for more info.

  • Sometimes /etc/X11/xorg.conf.d/10-backlight.conf happens to be necessary. Something like this:

    Section "Device"
        Identifier  "Card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
    EndSection
    
dell29 xps25 brightness15 93604 Posts 5Views 618
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.