So… yeah. I’m new here, just installed the latest GNOME Antergos, and I installed an extension which lets me see my CPU frequency on the desktop. So I’ve noticed the computer sometimes turns the overclock off (setting max freq at 2.7G instead of 3.5G). There isn’t a setting for overclock I can find in the BIOS, but whenever I access BIOS and then log back in the overclock turns on again. Is this a setting or bug or something that I can fix? Thanks.

Computer is a Lenovo Flex 4-1580, any help is appreciated.