• I can't get wifi working on my Macbook Pro, and I need help. Thanks!


    After trying around 20 different distros to replace OSX on my aging MacBook Pro, I’ve settled on Antergos. I love it.

    The only thing I haven’t been able to get working the way I want it is the internal wifi. I know for a fact that the card works, as it worked after installing drivers on various other distros, e.g. Ubuntu. I can’t get it working at all on Antergos. From what I can tell, the wifi card is a B43 Broadcom model. I’ve tried several of the drivers available for it, with no luck. I’m not sure if I’m missing something during the install process. I’m new to arch in general, so that may very well be the case. I can’t find any specific forum post that has solved my problem yet, so I thought I’d make my own.

    I’m currently using a USB wifi dongle, but would prefer to free up that port, though I’ll probably stay with Antergos either way.

    Any help and step-by-step instructions for dummies like me would be very much appreciated! I’m getting a little desperate as this is my third or fourth forum post trying to get this resolved.

  • Second post here😎
    To help you on that issue, we will need more info first and logs may also help to figure out what is going on.

    https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    Copy paste this command inside a terminal and post the url it gives out at the end

wifi130 macbook24 help18 pro15 Posts 2Views 206
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.