• Unable to boot into live O's (Nvidia issue?)


    For the past couple of days, I have been attempting to dual boot Windows and Antergos on my laptop (Dell XPS 15 9560). I’ve been able to get mint working but I decided I wanted a arch variant. However, I haven’t even been able to get into the live OS, which I am assuming is because of my dGPU (gtx 1050).

    I have tried the Nvidia fallback option, however, I am greeted with a black screen with a console cursor in the upper left. The regular live boot displays a white splash screen with the Antergos logo and then freezes.

    I’ve gone through a few threads on this forum and it seems this has been happening for a few years.

    https://forum.antergos.com/topic/7715/nvidia-installation-driver-blinking-cursor (User has a similar model as me and similar problems) however the launch options didn’t seem to help

    I’ve also tried using systemd.unit=multi-user.target and nomodeset to no avail.

    Disabling the dGPU is not an option in Bios. Secureboot has been turned off. Bootable USB was created in Rufus on a Windows 10 host.

    I was wondering if there are any easy fixes to disable the nouveau drivers or find a way to get into the live os so I can start installation.

    Thank you :)

    Feel free to let me know if anymore information is needed

  • @mattc said in Unable to boot into live O's (Nvidia issue?):

    I was wondering if there are any easy fixes to disable the nouveau drivers…

    Yes, there is. Add to the boot line


    The parameter completely excludes | disables | eliminates | removes nouveau from the started session.

  • @just

    I tried adding that to the boot arguments, however, I still seem to get a console cursor on boot. Does this mean its not a GPU issue? Hard to diagnose the problem when I can’t see anything

  • @mattc said in Unable to boot into live O's (Nvidia issue?):

    …Does this mean its not a GPU issue?..

    I don’t know. It may or may not be GPU-related. I’m not familiar with Nvidia GTX 10xx series cards.

    There are customized Antergos ISOs, made by @joekamprad some time ago. They were working for recent Nvidia 10xx cards. Their download URL may be found in forum posts.

    Hard to diagnose the problem when I can’t see anything

    That’s true.

  • If needed I can build and provide a Nvidia enabled Antergos ISO (with Nvidia drivers and boot option) my last build is to old for all current changes, and will not be able to install system…

  • @joekamprad If youd be willing to do that for me it would be greatly appreciated

    @just Ok thanks for your help!

  • @mattc i will, but will need some hours… i can try providing it inside next 8 hours ;)

  • @joekamprad Awesome, thanks so much

  • @mattc i get some problems building… will try it again at the moment :(

  • @joekamprad

    It worked :), thank you again!

  • @joekamprad hi, can you make a New build uptodate for me please, or à tutorial to make it, I run the Iso you link but when I hit install it show nothing and when I try to launch official I get all screen black with just à cursor

    I have GTX 970 and à titan xp

    Thanks you very mutch

  • @gilbertpaquin1995

  • But how I can pre-add it to Iso?

  • To do so you will needto rebuild the iso, after changing the configuration… i can provide an up to date nvidia enabled iso, but your cards should work with open source driver… and may something else is calling the issue for you…

  • If you can it will be nice, because this iso: http://kamprad.net/Downloads/Antergos-Nvidia-ISO/antergos-gnome-nvidia-nozfs-18.2-x86_64.iso seem work for me but when I hit install the app dosen’t open and with the original iso I just get a black screen with the mouse.

  • you can try updating cnchi inside also: sudo pacman -Syy
    sudo pacman -S cnchi

  • I found the issue it is because it missing 3-4 python module that is not on 18.2 I add them manualy and I can run the setup but gnome just give me a black screen with a mouse :(

  • Can you provide the missing packages as a list?

boot321 nvidia166 unable76 live59 Posts 19Views 1679
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.