• Graphical login screen fails to authenticate my password


    http://oi65.tinypic.com/fa09c3.jpg

    As the title says. I can’t log in from the graphical interface even after going to ctrl+alt+f2 and using the “passwd” command as root to change my user accounts password. Happened after a reboot. The password is correct and the account details work dandy from the terminal, though. It’s just that I can’t start the desktop enviroment, Gnome, from there either. “startx” fails.
    Pretty depressing. Any help is appreciated.

  • @superbee said in Graphical login screen fails to authenticate my password:

    I can’t log in from the graphical interface even after going to ctrl+alt+f2 and using the “passwd” command as root to change my user accounts password

    Hi!
    Not sure if this is your case but are you using a keyboard with another letters? (like greek, russian, etc) . If so try changing the password to something easier like letters and numbers only.

    “startx” fails

    Antergos has no configuration for startx that’s why the command can’t work. If you want to use it be sure to create 2 config files (xinitrx and xsession), following the archwiki guide https://wiki.archlinux.org/index.php/Xinit
    *Stop your login manager before startx.

  • I do have a keyboard with Latin as well as Cyrillic letters on it. That can’t be the problem though, as I set the password to only two numbers. Still, the graphical interface says it is invalid, fails to authenticate, while the password works in terminal.

    @fernandomaroto said in Graphical login screen fails to authenticate my password:

    Antergos has no configuration for startx

    Alright, thanks.
    So, the bottom line here is: there is no easy workaround to log in and reach my desktop enviroment?
    How could something like this even happen when I am absolutely confident about my password? An update?
    I’ll consider configuring startx because it’s either that, or a fresh install

  • @superbee said in Graphical login screen fails to authenticate my password:

    So, the bottom line here is: there is no easy workaround to log in and reach my desktop enviroment?

    What about the user name, it uses only letters?

    • from useradd manual page
    Usernames must start with a lower case letter or an underscore, followed by lower case letters, digits, underscores, or dashes. They can end with a dollar sign.
    

    I’ve only see that error with users that created weird user names or with the different keyboard writings…

    I wouldn’t vote that lightdm is buggy since your error is related with password…

    Creating config files and running startx is a way to workaround it…

  • Username: simon

    Looks pretty straight forward and unmistakable for me. No upper cases, no symbols, no numbers in both username and the password.

    Oh well, I guess I’ll start configuring startx then. It is not easy for me since I am a complete stranger in the Linux world, used Arch a few years ago, but that was just too comlicated for me.

    Thanks anyway

  • @superbee said in Graphical login screen fails to authenticate my password:

    It is not easy for me since I am a complete stranger in the Linux world

    Ok, i’ll give you a hand:

    access tty2, login (with username, not root) and:

    1. download xsession file i use
      wget codepad.org/L8Oggp2c
      rename it to proper name with:
      mv L8Oggp2c .xsession

    2. create .xinitrx file with
      nano .xinitrc
      inside it you must write your desktop of choice, in my case is
      exec i3
      If you’re using gnome is probably
      exec gnome-session
      press Ctrl+o to save ans Ctrl+x to exit

    also disable and stop lightdm.
    sudo systemctl disable lightdm
    sudo systemctl stop lightdm

    then startx

  • just in case also disable:

    systemctl disable multi-user.target

login117 fails35 graphical13 authenticate2 Posts 7Views 421
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.