• libjpeg-turbo and mozjpeg are in conflict


    so trying to install mycroft, and got

    resolving dependencies...
    looking for conflicting packages...
    :: libjpeg-turbo and mozjpeg are in conflict (libjpeg). Remove mozjpeg? [y/N] 
    error: unresolvable package conflicts detected
    error: failed to prepare transaction (conflicting dependencies)
    :: libjpeg-turbo and mozjpeg are in conflict
    [[email protected] mycroft-core]$
    

    Did some google fu and didn’t see much for Linux so anyone know whats going on? Way to much depends on mozjpeg.
    Thanks

  • @darkmavrik said in libjpeg-turbo and mozjpeg are in conflict:

    mozjpeg

    Hi!

    mozjpeg is from AUR, that means you installed it for some reason.

    If you don’t know why you installed it you can open pamac-manager search for it and check it’s details. Then only you are able to decide if you sould or not uninstall it.

  • @fernandomaroto thank you sir, I did look at it, spotify and LBRY and about 30 other things require it, as when I went to uninstall it I got this list of doom. what exactly what do these 2 packages do? and is their anyway to get them to not be in conflict? The mac article said they were conflicting over ports, but I really couldn’t find anything.

  • @darkmavrik said in libjpeg-turbo and mozjpeg are in conflict:

    what exactly what do these 2 packages do?

    I have no idea.

    And is their anyway to get them to not be in conflict?

    No, there is a way to packagers developers consider those files in that manner.
    I guess you’ll need to give up of one of them and find an alternative sofware to suply the abandonned one.

conflict9 libjpeg-turbo1 mozjpeg1 Posts 4Views 225
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.