• USB File Copy Stalls Randomly


    For some reason, every time I copy files from HDD to USB 3.0 flash drive, copy stalls for some time, and then continues.

    For example, if I copy many small files (like 5.000 files, while each file is 2-3 MB in size), system copies files very fast, and then copying gets slower… After ~300 files are copied, copying completely stops for 2-3 minutes. I mean, no single bit gets copied during this period. Then system unfreezes, and starts copying super-fast again. It copies another batch of files, and then stalls again…

    I thought it might be related to number of files (because copying many small files usually is slower than copying one big file), so I did experiments with big (2 GB file). The same story - system copies about 500 MB of that single file, and completely stops for 2-3 minutes. Later, it unfreezes, copies another ~500 MB of file in seconds, and stalls again. I wait 2-3 more minutes, system unfreezes again, copies ~500 MB (once again, in seconds) and stops completely. Finally, I wait 3 minutes again, and system copies remaining 500 MB of file in 5 seconds or so…

    The same happens when using KDE File Manager (Dolphin) or other programs like Beyond Compare. I also notices the same behavior when deleting files from USB - it deletes some files, freezes, and after 2-3 minutes starts deleting again…

    Flash drive is in perfect condition (I even bought new one today), so the issue must be somewhere else. Both HDD and USB have ext4 system.

  • Now I’m not so sure if problem is related to USB or system itself…

    Today I worked with directory on HDD, and it contained about 5000 files (each ~100 MB in size). Deleting them was slow as hell… System takes 1 second to delete 1 file, so if I select 30 files to delete, I need to wait 30 seconds (files slowly gets deleted one by one every second).

    Moving or copying many files (on local HDD, just between different directories) causes system to totally freeze for up to 2 minutes. I can’t even execute programs. If I leave KSysGuard running while files are copied, I see tons of processes with status “disk sleep”. Many of these processes are from apps that work with disk. For example, if I copy files using some 3rd party file manager, it stops copying and displays “disk sleep” in KSysGuard.

    I even attached a new HDD today for testing purposes, but it’s still the same. SO I guess it’s something software-related…

  • P.S. It also takes 1 second to delete small file. So if I select 100 small files to delete, it takes almost 2 minutes to complete. But if I select root directory (where files are stored), whole directory with files inside also gets deleted in 1 second.

  • Hi!
    I don’t an answer for you, but i confirm i experience the same bug copying files.

    Some times i think the files are corrupt or USB, then i try again and simply leave the file transference “stuck” on another deskop and forget about it. When i remember about the procedure is completed.

    I also noticed that using terminal to copy files is faster than using file manager (i use nemo here), but also see terminal “stuck” some times; again forget it and when i come back the procedure is finished again.

  • i would never use filemanager for copy large amount of data to usb flash drives… i use rsync for this…
    And if usb flash drive is formatted with fat32 or ntfs it is normal that there are delay between copy and sync …

  • Yes, if I leave copy process running, it eventually finishes.

    USB is formatted as ext4, just like HDD.

  • Another day, another story… Got another USB flash and started copying… This time, copy is slow as hell too, but not because of “disk sleep” process, but because CPU usage goes up to 100% when copying files. All 6 cores show 100% usage.

    Found many similar complains on the Internet, but most of them were old and solved by updating kernel… Unfortunately, there’s nothing to upgrade for me because I’m using the latest kernel already…

  • @toxpal
    interesting… I have 2 cores here only :(

  • Same issue if you take rsync?

  • @joekamprad

    In my case i just tested again, 324MB file took around 2 minutes to copy from pc (ext4) to Flash Drive (fat32), using rsync -a cp also used the same time…

usb101 randomly12 copy5 stalls4 Posts 10Views 257
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.