• Problem with update


    After run update there is error. I don’t know how to fix it.

    Synchronizing package databases...
    Refreshing antergos.db...
    Refreshing antergos.files...
    Starting full system upgrade...
    
    Resolving dependencies...
    Checking inter-conflicts...
    
    Failed to prepare transaction:
    could not satisfy dependencies:
    installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8
    
    
  • @miroslav said in Problem with update:

    …I don’t know how to fix it.

    By removing ffmpeg2.8.

    There’s no need tp have aur/ffmpeg2.8 installed. All sofiles, which itprovides, are also provided by the regular extra/ffmpeg package.

    You should have extra/ffmpeg installed. Not aur/ffmpeg2.8.

  • Ok. I removed aur/ffmpeg2.8 and try to update.
    The error is:

    Synchronizing package databases...
    Refreshing antergos.db...
    Refreshing antergos.files...
    Starting full system upgrade...
    
    Resolving dependencies...
    Checking inter-conflicts...
    Warning: dependency cycle detected:
    Warning: harfbuzz will be installed before its freetype2 dependency
    Warning: dependency cycle detected:
    Warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
    Downloading...
    Downloading playerctl-0.6.0-1-x86_64.pkg.tar.xz...
    Checking keyring...
    Checking integrity...
    Error: playerctl: signature from "Christian Rebischke (Arch Linux Security Team-Member) <[email protected]>" is unknown trust
    
    Failed to commit transaction:
    invalid or corrupted package:
    
    

    What to do now?

  • @miroslav said in Problem with update:

    Ok. I removed aur/ffmpeg2.8 and try to update.
    The error is:

    This is another error, unrelated to the first one. The first one - the conflict between ffmpeg and ffmpeg2.8 - is solved.

    I have no idea what playerctl package does and what it serves for. Please, share the full output of the command

    sudo pacman -Syyu
    
  • I update some of packages and remove and reinstall corrupted packages.
    Now everything looks like fine.
    Thanks!

Posts 5Views 772
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.