• Slow DNS responses


    Hi all,

    I’m experiencing very slow DNS responses in Antergos. Over 200 ms when using dig google.com. In Firefox I usually need to wait 4-5s before the “Looking up” disappears. I used to have Mageia and OpenSUSE on this computer and haven’t experienced the delays…

    My DNS is set to 192.168.0.1, which is my router. I’ve already searched this forum as well as arch and manjaro, but haven’t found a solution that would work.

    None of the below worked. So far, I’ve tried:

    1. Add “options single-request” to resolv.conf
    2. Enable nscd/systemd-resolved
    3. Reconfigure network manager with unbound
    4. disabled ipv6 via grub

    I’m out of ideas here… Any help will be much appreciated.

    Thanks

  • it would help to actually see your dig output. you’re overkil trying all these options without first finding out if it’s your dns that slow or your browser config and addons or restarting your router. have your tried any live linux to see if dns response is the same. usually you disable ipv6 in router if you have that option and leave kernel alone

  • HI,

    thanks for answering.

    I gave Firefox as an example. The problem occurs in all browsers, be it FF, Vivaldi,Chromium…

    Here’s my dig response:

    ; <<>> DiG 9.13.0 <<>> google.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24945
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;google.com.                    IN      A
    
    ;; ANSWER SECTION:
    google.com.             141     IN      A       216.58.212.78
    
    ;; Query time: 161 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Mon Jul 23 23:07:24 BST 2018
    ;; MSG SIZE  rcvd: 44
    

    One thing I’ve also noticed. When calling the dig multiple times, after every say 6th or so, there was a timeout.

    When I opened a second terminal and run:

    sudo tcpdump -n -i wlo1 |grep 192.168.0.1.53
    

    Then the timeout was much less frequent.

    Obviously then dmesg showed:

    device wlo1 entered promiscuous mode
    

    If it helps, I have Broadcom 43142 card and I’m using “wl” driver.

    Please let me know if there’s any other information you would like me to provide.

    Thanks

  • i use this DNS Benchmark but it uses .wine still it give a lot of useful info. https://www.grc.com/dns/benchmark.htm if you download and test it will tell you how fast your ISP dns is compared to others. after opening choose the Nameservers tab wait for update and the test will take a while. don’t surf the internet while testing

    they say the new one 1.1.1.1, 1.0.0.1 is the fastest.
    i use 84.200.69.80, 84.200.70.40 because of privacy and no logging

    do you know how to change dns using the desktop network manager? you have to turn off/on connection when changing to allow new dns restart

  • Hi,

    I’m sorry to say but it’s not an issue with my service provider. I used to run Mageia and OpenSUSE on this machine and there were no delays. I also have another computer running Mageia and DNS resolution is as fast as a blink of an eye, so I’m sorry but it’s a dead alley.

    I wanted to try Antergos/Arch as I have heard and read a lot of good about it. And I’ve managed to fix all other issues that I had apart from this one as it is configured vary different to the two aforementioned distros.

    As a partial answer to you question, I’ve also tried changing the DNS to google’s 8.8.8.8 and it’s still timing out. Changed the DNS to the ones you’ve mentioned and the issue persists.

    Hence, my question, what else can I try/reconfigure to fix the timeouts?

    Thanks

  • currently i get: but as i said i use dnswatch which i much slower but no logging

    ;; ANSWER SECTION:
    google.com.  149 IN A	172.217.6.78
    
    ;; Query time: 22 msec
    ;; SERVER: 1.1.1.1#53(1.1.1.1)
    ;; WHEN: Tue Jul 24 08:27:38 PDT 2018
    ;; MSG SIZE  rcvd: 55
    

    have you undone all the changes you made from your first post? what’s in your /etc/hosts how many errors you have for iwconfig

  • with 1.1.1.1:

    ; <<>> DiG 9.13.0 <<>> google.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46047
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1452
    ;; QUESTION SECTION:
    ;google.com.                    IN      A
    
    ;; ANSWER SECTION:
    google.com.             119     IN      A       216.58.213.110
    
    ;; Query time: 145 msec
    ;; SERVER: 1.1.1.1#53(1.1.1.1)
    ;; WHEN: Tue Jul 24 19:08:32 BST 2018
    ;; MSG SIZE  rcvd: 55
    

    I believe this problems needs to be looked at from a different angle as 145 or 200ms I could live with. It’s the timeout before I get the response from DNS server that seems to be the issue. As I said the same router is used for different computers and it was used on this computer in a different distro and the problem was not occuring. Come to think about it more and more, the 200ms response from the DNS server shouldn’t end up as a 5s delay in the browser, should it?

    I don’t really know how to diagnose that timeout. So, what I mean is that I call dig and then I wait until I see the response. Sometimes it’s immediate sometimes it’s several seconds. I would like to know what is happening at this point as it seems that this is where the root of this problem lies.

  • in chrome bottom left status bar when you open page do you see Resolving host ... open a page like yahoo.com which is splattered with advertising and takes longer to load
    you didn’t comment on /etc/hosts and iwconfig

  • Hi,

    apologies for not coming back to you earlier…

    My content of /etc/hosts is populated from https://github.com/StevenBlack/hosts with the base one. I’ve also tried reverting to the original hosts file, but it had no influence.

    The most annoying is that I don’t know how to debug the issue and which part of the configuration is failing. I’ve looked at the driver kernel options as this is happening system wide but I cannot find any documentation as to what they could/should be set to.

    modinfo wl
    filename:       /lib/modules/4.17.11-arch1/kernel/drivers/net/wireless/wl.ko
    license:        MIXED/Proprietary
    srcversion:     2276F6FE4F2C368B4A2F3EE
    alias:          pci:v*d*sv*sd*bc02sc80i*
    depends:        cfg80211
    retpoline:      Y
    name:           wl
    vermagic:       4.17.11-arch1 SMP preempt mod_unload modversions 
    parm:           passivemode:int
    parm:           wl_txq_thresh:int
    parm:           oneonly:int
    parm:           piomode:int
    parm:           instance_base:int
    parm:           nompc:int
    parm:           intf_name:string
    

    After the kernel upgrade the issue has become intermittent, so there are times when it works flawlessly and times when I get the timeout, which made me wonder about the driver in the first place.

    About the iwconfig errors. Did you mean the ifconfig tx/rx errors or sth else?
    There’s the ifconfig errors count below:

    RX packets 1435391  bytes 2084116993 (1.9 GiB)
    RX errors 0  dropped 0  overruns 0  frame 1003497
    TX packets 592193  bytes 49650727 (47.3 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    

    I’ve also found some info about setting options timeout:1 in the resolv.conf file, but networkmanager keeps overwriting it and it doesn’t stick. I don’t know where in arch I could add the RES_OPTIONS to the resolver. In Mageia it was /etc/sysconfig/network. Would you know how to add it to the resolv.conf permanently? Previously when testing the other options single-domain, I simply changed the permissions on the file, but that doesn’t feel like a correct way moving forward.

  • all i need is the first few lines of your /etc/hosts and the output of iwconfig not ifconfig. and do you see chrome saying Resolving host ... when you open it at the bottom left status bar

    if you reset your hosts to original did you restart the connection usually disable and enable networking in network tray icon

slow31 dns5 responses2 Posts 10Views 422
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.