• GUI not starting Nvidia K2000M

    Re: Nvidia K2100M does not boot after installing nvidia driver

    I found the thread above and now I am facing the same problem on my Laptop I reinstalled Antergos to get rid of Bumblebee, since it is absolutely broken after Xserver Update to 1.20. And I decided to go solely with the Nvidia Drivers.

    On the standard Nouveau Driver Gnome was starting fine, but after installing Nvidia Drivers with the Nvidia-Installer Script, I only get the Black Screen with the little dash. And Gnome does not start.
    Booting into terminal command line works fine and when I checked the Xsessionerrors, I only get a weird error message:
    “Light Locker: Fatal Error IO Error 11”
    Sadly I cannot find anything how to fix this problem.
    Trying to startx brings up nothing, just a freeze where nothing happens and having to switch to a different Tty for shutting down.
    I made a Photo of these errors:
    ![0_1532116417166_IMG_20180720_215325.jpg](Uploading 100%)

    Will edit this post, with some of the configs if it helps. Just trying to get these, since I only have my Phone for writing anything without a gui.

    My Laptop:
    Lenovo ThinkPad W530 with Nvidia Quadro K2000M. I know it should work with the Nvidia Driver alone, was using it before switching to Antergos and Gnome.

  • @severus said in GUI not starting Nvidia K2000M:

    …I reinstalled Antergos to get rid of Bumblebee, since it is absolutely broken after Xserver Update to 1.20…

    Please, avoid doinng strong, incorrect declarations, which don’t correspond to the reality.

    Bumblebee might not work or is not correctly installed on your hardware. It doesn’t mean that it is broken.

    Bumblebee continues to work perfectly, with most recent proprietary Nvidia drivers and on the most recent Xorg server on other hardware. For example, on Nvidia GT 555M, GT 650M, GT 750M.

    $ echo "--" && date +"%Y-%m-%d %H:%M:%S" && echo "--" && pacman -Q bumblebee nvidia xorg-server && echo "--" && optirun inxi -Gxzc0
    2018-07-21 08:33:52
    bumblebee 3.2.1-18
    nvidia 396.24-18
    xorg-server 1.20.0-9
    Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
               Card-2: NVIDIA GK107M [GeForce GT 750M] driver: nvidia v: 396.24 bus ID: 01:00.0 
               Display: x11 server: X.Org 1.20.0 driver: modesetting unloaded: fbdev,intel,vesa 
               resolution: 1920x1080~60Hz 
               OpenGL: renderer: GeForce GT 750M/PCIe/SSE2 v: 4.6.0 NVIDIA 396.24 direct render: Yes 


  • @just Bumblebee worked perfectly for me on the same Hardware before this updates, without any noticeable changes. So to me it is broken.
    As in another thread, Bumblebee makes no sense when it lets the Nvidia Card Running all the time, which wasn’t a problem before the updates. And it seemed like no one was able to help, since there wasn’t any posts to that I posted months ago.

    I really just want to switch to the Nvidia Driver permanently now, but really have no idea how to do that since
    Nvidia-installer script seemed to be a failure for me. It was installing fine, but afterwards I can’t boot into graphical.
    Would be nice if someone could actually help 😣.

    I will provide any photos or other info I can.

  • @severus said in GUI not starting Nvidia K2000M:

    Nvidia Quadro K2000M

    what nvidia driver is installed at your system then? as it seems that your card needs the nvidia-390xx one.
    0_1532160747715_Bildschirmfoto vom 2018-07-21 10-11-26.png

    And bumblebee is for sure not broken … there was an issue with the propritary nvidia drivers developed as closed source by nvidia company itself, and the issue was only related to xorg-server version and the driver…


  • Okay, well what I did after reinstalling Antergos:
    -Fixing Language to be able to get into Gnome Terminal
    -Installed Nvidia Installer

    Then I used:
    ‘’‘sudo nvidia-installer’’’
    Which seems to installed correctly as it broughf up no errors. But Rebooting well stops at a black screen with a little dash at the top left.

    Check the Installed Driver with:
    ‘’‘pacman -Qs nvidia’’’
    It gives me these packages besides the Nvidia Installer itself:
    nvidia 396.24-18
    nvidia-settings 396.24-1
    nvidia-utlis 396.24-2
    Plus some libraries, Here is a photo of the complete information:
    alt text

    When trying to start X from Command line nothing really happens until it times out, I guess. Just stays like this forever:
    alt text

    Xorg.0.log looks like this:
    alt text

    I hope you can see these pictures, Not really sure how exactly to copy text from logfiles without a functioning computer with graphical user interface.
    I can’t even go back to Noveau since nvidia-installer is not installing this.

  • Okay I officially can’t find out how this Pictures button works, doesn’t even show the links and most certainly not the photos. For uploading file size is too big…

    Let’s try again, since the forum won’t let me edit the post, always getting a connection was lost error…

    1. Picture of installed packages:

    2. Startx:

    3. Xorg.0.log

  • @severus said in GUI not starting Nvidia K2000M:


    your graphiccard is not supported by this driver. This is what i give you before…

  • Is there a tutorial somewhere here which I overlooked how to get the Nvidia-Installer to install the correct driver?
    I was under the impression the Nvidia-Installer would pick the correct one… And I thought 396 is just a version of 390xx… How should I have known Nvidia-Installer installs just what it wants.

    I am really sorry if I overlooked a Tutorial somewhere here, but I don’t really understand why anyone is so aggressive here.
    Sometimes Antergos is quite difficult for me…

    I was really happy with using Bumblebee for quite some time.
    But after the Updates of Nvidia Drivers, and Xserver 1.20. It was not switching of the Nvidia Card anymore… I really don’t care whose fault it is if Nvidia or X or whatever. I just need a working PC.
    But it is quite obvious that Bumblebee was broken on my laptop after these updates. And it really was working perfectly for me before and I searched for a solution for weeks, but on my post then there was barely a reply…
    And my understanding of Bumblebee is certainly the purpose to switch of the Nvidia Card if not in use, an ability these updates broke… And if no one here knows how to fix these problems, how should anyone without great programming skills have any chance to fix these problems???

  • @severus said in GUI not starting Nvidia K2000M:

    but I don’t really understand why anyone is so aggressive here.

    We only want to get you to the right point.
    Antergos Forum is one of the most friendly community around.

    On your issue with nvidia-installer:
    May your card is wrongly detected, or it fails to install, as long as you do not provide exact output it is diggin in the dark… and also may nvidia-installer is not able to detect legacy 390xx cards at all ?

    you can provide this and the journal to get me be able to help you here:

    nvidia-installer -t | curl -F [email protected] https://ptpb.pw/?u=1
    journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1
    and post the short url it gives out at the end

  • Of course. Sorry it took me so long, needed to find a way for getting internet access without wifi.

    The first Url for the Nvidia Installer:

    The second Url for Journalctl:

  • Sorry… Again… I just don’t get this forum syntax and also are not allowed to edit the post as it seems…
    1 Link:
    2. Link:

  • @joekamprad said in GUI not starting Nvidia K2000M:

    nvidia-installer -t

    do not show any log you need to provide:

    cat /tmp/nvidia-installer.log | curl -F [email protected] https://ptpb.pw/?u=1

  • Sorry seems lik I made an error there, here again with test mode.

  • You need to run without sudo in test mode

  • Run:

    nvidia-Installer -t

    And then what I give you before

  • Just a side note.

    nvidia-installer’s --test modes and results are different for single and hybrid GPUs Nvidia cards.

    To test nvidia-installer on single GPU Nvidia it should be run as:

    nvidia-installer --test

    To test nvidia-installer on hybrid GPU Nvidia it should be run as:

    nvidia-installer --test  --bumblebee

    In other words:

    • without --bumblebee option nvidia-installer is tested for simple Nvidia cards.

    • with --bumblebee option nvidia-installer is tested for Optimus Nvidia cards.

    If nvidia-installer is run without --bumblebee option on Optimus card, it doesn’t install Nvidia driver corrrectly. The system won’t boot.

    nvidia-installer must be always run with --bumblebee option on Optimus cards.

  • @joekamprad
    Here is another link. I hope this works for you. The description you gave was what I did before, but well maybe I did something wrong.


    @just I don’t understand, what do you mean? Can you explain a little more detailed to help me understand please?
    I don’t want to have anything to do with Bumblebee anymore, at least not until it finally works again on my laptop. I don’t have another PC, but my Laptop so I cannot afford to have this F… on it right now. Maybe I will be willing to give it another try in a couple of months, when there might be a chance it will turn off the Nvidia Card again when not in use.
    I also know that my Laptop is capable of running on the Nvidia Driver Solely, since it worked with 3 Distributions before. Never had it under Antergos though, but that shouldn’t limit the Functionality I guess.

  • @severus So nvidia-installer is installing latest nvidia drivers… but as far as i can see your card is a legacy 390xx card and you will need to install this driver sudo pacman -S nvidia-390xx

  • @severus said in GUI not starting Nvidia K2000M:

    @just I don’t understand, what do you mean?..

    I mean that nvidia-installer works differently for two different types of Nvidia cards - single GPU and hybrid GPU cards. Installs different packages, configures the system differently.

    nvidia-installer doesn’t try to detect the type of a card - whether it is simple or hybrid card. It’s up to user to know what card he has, and tell to nvidia-installer in what mode it should run. It is done thanks to using --bumblebee switch:

    • without it nvidia-installer operates for single GPU Nvidia cards
    • with it nvidia-installer operates for hybrid GPU Nvidia cards

    Using a wrong nvidia-installer’s operation mode for a specific Nvidia will result in unbootable system.

nvidia166 starting25 gui25 k2000m1 Posts 28Views 1026
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.