• Can’t create download package list.... - how to proceed


    Dear community,

    When I’m trying to install antergos everything works very good until I hit next after filling out the computer name and username/password and after that i just get “Can’t create download package list. Check log output for details”. - Well this has been discussed several times so far.

    i have used the 64 bit live and minimal iso files downloaded today - to install on a Notebook.

    Question : should i download a new iso and try it out with another or not!?

    In other words - can i try out with the same USB.Stick with the installer-medium ?

  • I’m having the exact same issue you are describing. I’m trying to install Antegros 18.7 (currently the latest) using the 64 bit live on a GNOME Boxes VM.

    0_1531862527141_Screenshot from 2018-07-17 23-15-43.png

    The last lines that Cnchi outputs on terminal are the follwing:

    2018-07-17 20:44:10 [DEBUG] select_packages.py(361) select_packages(): Packages list: system-config-printer,python-pyqt5,bluez-utils,darkhttpd,base,unzip,btrfs-progs,acpid,playonlinux,gpm,screenfetch,vim,openssh,antergos-mirrorlist,pkgfile,terminus-font,gnu-netcat,clonezilla,python2-gnomekeyring,cups-pk-helper,haveged,espeak,antergos-common-meta,pulseaudio-bluetooth,git,aurman,unrar,gnome-bluetooth,usb_modeswitch,mc,reflector,whois,gzip,steam,f2fs-tools,wget,dnsmasq,lftp,efibootmgr,antergos-desktop-settings,orca,bluez,b43-fwcutter,gsfonts,reiserfsprogs,e2fsprogs,ethtool,networkmanager,cifs-utils,antergos-gnome-meta,dhclient,brltty-minimal,os-prober,intel-ucode,elinks,sudo,bind-tools,bash-completion,ipw2100-fw,gufw,nilfs-utils,grub2-theme-antergos,bluez-libs,firefox,cups,flashplugin,bzr,tar,net-tools,ntfs-3g,wireless_tools,exfat-utils,irssi,htop,dosfstools,wpa_actiond,cmake,ipw2200-fw,modemmanager,lib32-libldap,python2-speechd,chromium,hplip,antergos-keyring,python-gobject,alsa-utils,grub,xfsprogs,ufw,base-devel,jfsutils,nfs-utils,ddrescue,yaourt,antergos-midnight-timers,steam-native-runtime,xf86-video-vesa,mlocate,pepper-flash,splix,dmraid,cryfs,crda,espeakup
    2018-07-17 20:44:10 [DEBUG] select_packages.py(111) create_package_list(): Packages selected
    2018-07-17 20:44:10 [DEBUG] pac.py(122) initialize_alpm(): ALPM initialised with root dir / and db path /var/lib/pacman
    2018-07-17 20:44:10 [DEBUG] pac.py(98) __init__(): ALPM repository database order is: ['antergos', 'core', 'extra', 'community', 'multilib']
    2018-07-17 20:44:10 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:11 [INFO] slides.py(276) manage_events_from_cb_queue(): Creating the list of packages to download...
    2018-07-17 20:44:11 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:11 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:11 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:12 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [WARNING] metalink.py(342) build_download_queue(): Error reading group 'cinnamon' from the antergos repo db
    2018-07-17 20:44:13 [ERROR] metalink.py(132) create(): Can't resolve these dependencies: hunspell-es 
    2018-07-17 20:44:13 [ERROR] download.py(150) create_metalinks_list(): Error creating metalink for package antergos-common-meta. Installation will stop
    2018-07-17 20:44:13 [ERROR] download.py(182) create_metalinks_list(): Can't create download set. An exception of type InstallError occured. Arguments:
    ('Error creating metalink for package antergos-common-meta. Installation will stop',)
    2018-07-17 20:44:13 [ERROR] process.py(130) run(): 'Cannot create download package list (metalinks).'
    2018-07-17 20:44:13 [ERROR] process.py(135) run(): Traceback (most recent call last):
    2018-07-17 20:44:13 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/process.py", line 92, in run
        self.create_metalinks_list()
    2018-07-17 20:44:13 [ERROR] process.py(135) run():   File "/usr/share/cnchi/src/installation/process.py", line 82, in create_metalinks_list
        raise misc.InstallError(txt)
    2018-07-17 20:44:13 [ERROR] process.py(135) run(): misc.extra.InstallError: 'Cannot create download package list (metalinks).'
    
  • I have the same error, in both computer, 64bits using bios… in two diferent computers

  • well - i would be more than glad if any body can help here.

  • I confirm I have the same error here

  • Hi everyone! Fairly new to Linux, totally new to Arch, so please be gentle.

    I’m getting the exact same error as @JD342 above. Trying to reinstall Antergos 18.6 with Gnome on the same machine from a Live CD that worked perfectly fine just a week ago. Cnchi is 0.14.426. Here’s an example log:
    cnchi.log (Pastebin)

    I get exactly the same warning as above (Error reading group ‘cinnamon’ from the antergos repo db) followed by an error (Can’t resolve these dependencies: hunspell-es ).

    I’ve tried the following:
    using default mirrors instead of recommended
    manually selecting mirrors
    installing without any optional packages

    I’ve tried what @joekamprad suggested in this thread:
    Can’t install necessary packages. Cnchi can’t continue..

    Using this custom mirror list seemed to work for the OP but it only breaks Cnchi for me. First I get this:
    Loading, please wait
    It just says “loading, please wait” for several minutes after I click on Install It. If I click again I can continue but only until the Location selection screen, where, when I select the location, see below:
    alt text
    This happens:
    alt text
    Notice that the message on the top changes to ‘Choose installer language’ which I already did. At this point I’m unable to proceed with the installation and I can just close Cnchi.

    Could there be an issue with this hunspell-es package? Background story, my Antergos worked fine until yesterday when I tried updating it and received some error about the dependency issue with hunspell. This prevented me from updating anything. Feeling brave and smart, instead of looking this up I figured I could just uninstall hunspell from the system completely (it’s just a spellchecker, right?). Restarted, couldn’t load into GUI at all, Light DM failure. This is a whole reason I am reinstalling (this is my secondary machine so not a big deal, but still…).

    Would appreciate any ideas on what to do next.

  • @jd342 got exactly the same Error here!

  • Seeing the exact same problem, must be an issue with the server

  • Looks like it’s the problem on their side. We’ll wait, what else can we do.

  • @sudo-rm
    I think you got it right, as I said in my own post regarding this same problem.

    I have been reading the forum and there seems to be an error with hunspell-es dependencies, in people with Antergos already installed.

    So it seems this is the problem:

    [ERROR] metalink.py(132) create(): Can’t resolve these dependencies: hunspell-es
    

    and that it’s no installation error, but a whole system one.

  • @digital99
    Yeah, that makes sense. So, if the hunspell dependecies are to blame I guess we can either wait for them to be fixed (could take days, maybe more) or we can find a workaround to somehow exclude them from the installation process.

    Seems like something like this already happened but with some Celementine dependancies:
    Cnchi installing problems
    Antergos installer crashes at the end

    Someone posted a workaround on removing Clementine dependencies from antergos-kde-meta:
    https://gist.github.com/ricjac/31b1b2932195bcdcb0f75ab5f08dc0df

    Could something like this, so removing hunspell-es from antergos-common-meta, be a temporary solution?

  • I have the same error

  • @sudo-rm said in Can’t create download package list.... - how to proceed:

    @digital99
    Yeah, that makes sense. So, if the hunspell dependecies are to blame I guess we can either wait for them to be fixed (could take days, maybe more) or we can find a workaround to somehow exclude them from the installation process.

    Seems like something like this already happened but with some Celementine dependancies:
    Cnchi installing problems
    Antergos installer crashes at the end

    Someone posted a workaround on removing Clementine dependencies from antergos-kde-meta:
    https://gist.github.com/ricjac/31b1b2932195bcdcb0f75ab5f08dc0df

    Could something like this, so removing hunspell-es from antergos-common-meta, be a temporary solution?

    I followed steps in these post to remove hunspell but the cinnamon group still gives an error for a package called ‘zd1211-firmware’ that is not listed in it’s pkglist so I think it must be a network-related dependancy. I don’t actually need it since I’m on a wired connection atm if anyone spots it, I’ll upload all my docs if I have any success but I did get past the antergos-common-desktop one

  • I found a workaround but this site will NOT LET ME POST IT and flags the text as spam, please read it here if you would like to proceed with the install https://ghostbin.com/paste/bowqc

  • @andreasmgott Thanks, it worked!

  • Are you guys able to install Antergos now?

  • hello dear - i will try out later the day.

    well i need to folloow all the steps

    i hope it will work - if not - i will come back here

  • @andreasmgott said:
    I followed steps in these post to remove hunspell but still gives an error for a package called ‘zd1211-firmware’

    Ah, this firmware was actually listed right in the same list of /usr/share/cnchi/data/packages.xml under <edition name=common at the very top! The <pkgname>
    entry will be at the bottom of this list, and upon removing it I can proceed with my install! A successful workaround for me. Heres all the steps I took

    1. Boot from Live usb, allow cnchi to update, close it!
    2. sudo pacman -S gedit lynx
    3. lynx ghostbin.com/paste/zz2c3
    4. Accept cookies, use P and select the option to print the main screen
    5. Copy the list where it starts at <pkgname> and ends at </pkgname> with several inbetween
    6. sudo gedit /usr/share/cnchi/data/packages.xml, at the top there is a edition called “common”
    7. Remove the last <pkgname> for zd1211-firmware (may be a wifi driver, I cannot confirm if your specific install needs or not, but it must be done to proceed)
    8. Find edition directly under it called “graphic”, and replace the <pkgname>antergos-common-meta</pkgname> with our big list of pkglists
    9. Save, and now run cnchi -p /usr/share/cnchi/data/packages.xml and everything can proceed!
  • @malaga said in Can’t create download package list.... - how to proceed:

    still gives an error for a package called ‘zd1211-firmware’

    Hi!
    AFAIK the package was removed from archlinux repositories; since it doesn’t exist anymore you’ll always get errors with it (unless you manyually remove that package from the list).

    I guess new antergos iso has the most up to date packages, so be sure you’re using the new one and not an old iso version.

download31 list4 proceed2 can’t2 Posts 30Views 3682
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.