• Cant solve dependencies (hunspell)


    Today i cant update my system because this problem.
    Removing hunspell-es breaks dependency, ‘hunspell-es’ is needed by antergos-common-meta.

    I wonder a litte why antergos wants do remove this package.

    How can i solve this ?

  • Upgrading with pacman shows me, that hunspell-es wants to be replaced by hunspell-es_any. But it isnt possible because hunspell-es is needed by antergos-common-meta.

  • Same problem here. After attempting to upgrade system I’m met with:

    :: Replace hunspell-es with extra/hunspell-es_any? [Y/n]
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: removing hunspell-es breaks dependency 'hunspell-es' required by antergos-common-meta
    
  • could not satisfy dependencies:
    removing hunspell-es breaks dependency ‘hunspell-es’ required by antergos-common-meta

  • same problem, can’t upgrade

  • Same problem here. Cannot upgrade my system.

  • I just answered ‘n’ at the prompt and it updated the system normally. Afterwards it shows my system is up to date.

  • @bmcnick Same here, but the problem persists as the question “Replace hunspell-es with extra/hunspell-es_any?” every time I try to upgrade the system. Answering no every time is quite annoying.

  • I have the same problem, how can I solve it?

  • Just put the hunspell-es on the ignore list, untill it gets resolved and everything else gets updated.

  • The problem no longer occurs for me.

  • An update to antergos-common-meta seems to have been pushed through. That was quick.

  • @grenouille , Yes I managed to update successfully myself, as well, and after re-boot absolutely no hicks - the developers were really proactive there. Kudos to all !👍

  • I still can’t update 😧

  • @fnc can you give the output of try to update?
    e-g- –

    sudo pacman -Syu

  • @joekamprad said in Cant solve dependencies (hunspell):

    @fnc can you give the output of try to update?
    e-g- –

    sudo pacman -Syu

    $ sudo pacman -Syu
    
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
    :: Replace hunspell-es with extra/hunspell-es_any? [Y/n] y
    warning: pepper-flash: local (1:26.0.0.137-1) is newer than extra (30.0.0.134-1)
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: removing hunspell-es breaks dependency 'hunspell-es' required by libreoffice-extension-dictionaries-es
    
    
  • uninstall libreoffice-extension-dictionaries-es do the update and reinstall it, but may as it is a AUR build it is not updated to fit the last change on hunspell.

dependencies18 hunspell5 solve2 Posts 17Views 1653
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.