• Can not boot anymore after linux / linux-lts upgrades


    Hi, I can not boot after upgrades. In those upgrades I got kernel updates, but also other updates. The first upgrade, which included an update for linux-lts brokes the the linux-lts kernel boot.

    broken linux lts boot screen

    After that I used the linux boot, which worked, but today, I got also an update for the stable linux kernel and got the following screen after reboot.

    broken linux boot screen

    How to fix this problem? Maybe the problem is not the kernel update. Maybe a systemd update or something else?

  • Hi, I can not boot after upgrades. In those upgrades I got kernel updates, but also other updates. The first upgrade, which included an update for linux-lts brokes the the linux-lts kernel boot.

    https://imgur.com/a/vIwumIP

    broken linux lts boot screen

    After that I used the linux boot, which worked, but today, I got also an update for the stable linux kernel and got the following screen after reboot.

    https://imgur.com/a/m5qoPL3

    broken linux boot screen

    How to fix this problem? Maybe the problem is not the kernel update. Maybe a systemd update or something else?

    BTW: It seems that the forum image upload does work.

  • https://wiki.archlinux.org/index.php/microcode

    looks like microcode update failed?

  • Some microcode issue, just as Joe suggested.
    And maybe motherboard BIOS/firmware update needed?

  • The intel-ucode package was not installed.:

    ~> pacman -Qi intel-ucode 
    Fehler: Paket 'intel-ucode' wurde nicht gefunden
    

    I installed it: sudo pacman -S intel-ucode. After that I updated GRUB.:

    ~> sudo grub-mkconfig -o /boot/grub/grub.cfg
                                   
    GRUB-Konfigurationsdatei wird erstellt …
    Thema gefunden: /boot/grub/themes/Antergos-Default/theme.txt
    Found Intel Microcode image
    Linux-Abbild gefunden: /boot/vmlinuz-linux-lts
    initrd-Abbild gefunden: /boot/initramfs-linux-lts.img
    Found fallback initramfs image: /boot/initramfs-linux-lts-fallback.img
    Linux-Abbild gefunden: /boot/vmlinuz-linux
    initrd-Abbild gefunden: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
     /dev/sdc: open failed: Kein Medium gefunden
     /dev/sdd: open failed: Kein Medium gefunden
     /dev/sde: open failed: Kein Medium gefunden
     /dev/sdc: open failed: Kein Medium gefunden
     /dev/sdd: open failed: Kein Medium gefunden
     /dev/sde: open failed: Kein Medium gefunden
    erledigt
    

    Then I checked for the microcode update.:

    ~> dmesg | grep microcode
    [    0.000000] microcode: microcode updated early to revision 0x24, date = 2018-01-21
    [    0.621286] microcode: sig=0x306c3, pf=0x2, revision=0x24
    [    0.621417] microcode: Microcode Update Driver: v2.2.
    

    It seems to me, that the microcode got updated, because before I got the following message.:

    ~> dmesg | grep microcode
    [    0.000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)
    [    0.621839] microcode: sig=0x306c3, pf=0x2, revision=0x1c
    [    0.622049] microcode: Microcode Update Driver: v2.2.
    

    But the problem is not gone.

  • Sometimes I get the emergency mode. Then I can enter my password and if I then type exit, I get the GDM login screen and can normally use my computer.

    https://imgur.com/a/aT4Uh6P

    emergency mode screen

  • try re-install linux, boot with live:

    su
    mount /dev/sdb4 /mnt         #  change the device names accordingly with your system 
    arch-chroot /mnt
    pacman -Syyu
    pacman -S linux
    mkinitcpio -p linux
    grub-mkconfig -o /boot/grub/grub.cfg
    exit
    umount -R /mnt
    reboot
    
  • mkinitcpio -p linux-lts
    

    Is what I would do first and regenerate grub.cfg.

  • @joekamprad said in Can not boot anymore after linux / linux-lts upgrades:

    mkinitcpio -p linux-lts
    

    Is what I would do first and regenerate grub.cfg.

    Unfortunately that did not help.

  • @trytip said in Can not boot anymore after linux / linux-lts upgrades:

    try re-install linux, boot with live:

    su
    mount /dev/sdb4 /mnt         #  change the device names accordingly with your system 
    arch-chroot /mnt
    pacman -Syyu
    pacman -S linux
    mkinitcpio -p linux
    grub-mkconfig -o /boot/grub/grub.cfg
    exit
    umount -R /mnt
    reboot
    

    Why with “live”, if I sometimes can login to my system?

  • @buzz-dee

    Hi friend!

    Can you recheck your partitions at fstab? Maybe UUIDs were changed in case you formated then or something like that.

    https://bbs.archlinux.org/viewtopic.php?id=195102

    https://bbs.archlinux.org/viewtopic.php?id=238554

    I guess you’ll need some trials and errors to fix/workaround that…

  • when you boot it sometimes boots and sometimes it doesn’t? i don’t understand. when you completely have power off and you boot what now happens?
    do you have nvidia? did you install nvidia-lts?

  • @buzz-dee https://wiki.archlinux.org/index.php/Trusted_Platform_Module

    on top of both pictures you have this tpm errors… may on some magical issue secure boot is reanabled at your machine?

  • @fernandomaroto I have nothing changed there, but here are my setting.:

    /etc/fstab:

    12 # /etc/fstab: static file system information.
    11 #
    10 # Use 'blkid' to print the universally unique identifier for a
     9 # device; this may be used with UUID= as a more robust way to name devices
     8 # that works even if disks are added and removed. See fstab(5).
     7 #
     6 # <file system> <mount point>   <type>  <options>       <dump>  <pass>
     5 #
     4 UUID=25546b7f-72b3-4f73-b790-a383ae90330c / ext4 defaults,rw,noatime,discard 0 1
     3 UUID=4d37b9c6-2d26-420c-be46-78c1f9c66c42 /home ext4 defaults,rw,relatime,data=ordered 0 0
     2 UUID=851fe218-deb7-4afb-a445-93006e7dd335 swap swap defaults 0 0
     1 UUID=51A5-8449 /boot/efi vfat defaults,rw,noatime 0 0
    13  tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
    
    ~> sudo blkid 
    [sudo] Passwort für sschlatow: 
    /dev/sdb1: LABEL="home" UUID="4d37b9c6-2d26-420c-be46-78c1f9c66c42" TYPE="ext4" PARTUUID="110eb793-5ea2-49ad-8bcf-555bf1265874"
    /dev/sda1: LABEL="swap" UUID="851fe218-deb7-4afb-a445-93006e7dd335" TYPE="swap" PARTUUID="d72c4a74-fcd6-498a-913e-b78f28327169"
    /dev/sda2: LABEL="efi" UUID="51A5-8449" TYPE="vfat" PARTUUID="937471ed-55b5-409c-ba3e-ff7728d7a2e2"
    /dev/sda3: LABEL="system" UUID="25546b7f-72b3-4f73-b790-a383ae90330c" TYPE="ext4" PARTUUID="811a594b-c86d-4189-b632-7bcfd3383b6e"
    ~> lsblk -f
    NAME   FSTYPE LABEL  UUID                                 MOUNTPOINT
    sda                                                       
    ├─sda1 swap   swap   851fe218-deb7-4afb-a445-93006e7dd335 [SWAP]
    ├─sda2 vfat   efi    51A5-8449                            /boot/efi
    └─sda3 ext4   system 25546b7f-72b3-4f73-b790-a383ae90330c /
    sdb                                                       
    └─sdb1 ext4   home   4d37b9c6-2d26-420c-be46-78c1f9c66c42 /home
    sr0                                                       
    ~> ls -l /dev/disk/by-partuuid/
    insgesamt 0
    lrwxrwxrwx 1 root root 10 23. Jul 10:23 110eb793-5ea2-49ad-8bcf-555bf1265874 -> ../../sdb1
    lrwxrwxrwx 1 root root 10 23. Jul 10:23 811a594b-c86d-4189-b632-7bcfd3383b6e -> ../../sda3
    lrwxrwxrwx 1 root root 10 23. Jul 10:23 937471ed-55b5-409c-ba3e-ff7728d7a2e2 -> ../../sda2
    lrwxrwxrwx 1 root root 10 23. Jul 10:23 d72c4a74-fcd6-498a-913e-b78f28327169 -> ../../sda1
    
  • @trytip I’m using extra/xf86-video-nouveau.

  • @joekamprad I already googled the error in the past and my
    finding was that I can Ignore it. Also it never has prevented me from login. I have checked the UEFI / BIOS and secure boot is disabled.

  • @buzz-dee
    Maybe it’s indeed kernel related. I’m having prolems with kernel since 2 months ago, but for me since 4.17-4-1 the problems are gone again; now i’m running 4.17.8-1

    Can you downgrade linux and linux-ltsto a version that your system booted fine for testing?

  • It seems it is related to the GNOME display manager gdm. If I do the following:

    sudo systemctl disable gdm.service
    sudo systemctl enable lightdm.service
    

    and then reboot, I can login to the system.

  • @BuZZ-dEE said in Can not boot anymore after linux / linux-lts upgrades:

    It seems it is related to the GNOME display manager gdm. If I do the following:

    sudo systemctl disable gdm.service
    sudo systemctl enable lightdm.service
    

    and then reboot, I can login to the system.

    https://bbs.archlinux.org/viewtopic.php?id=241432

boot278 anymore13 linux-lts7 upgrades6 Posts 20Views 993
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.