• Plymouth often causing boot freeze after full system upgrade


    After my recent full upgrade (I have not been using this PC for about three month so I upgraded a lot) I have a weird issue that does only let me boot after a couple of forced reboots.
    The first few times I boot it will freeze just before the screen normally turns off for a second before showing the login screen. After pressing the reboot button on my PC it will work eventually. Which is really odd to me.

    When it fails booting, one of the last lines of the journal says
    systemd[531]: emergency.service: Executable /bin/plymouth missing, skipping: No such file or directory
    Which should be the cause problem, since how I understand plymouth is responsible for bootsplash (which I turned off) and user interaction before login.
    What baffles me is that after some forced reboots it will randomly work again.

    Pastebin of journals:
    successful boot
    failed boot before that

    A web search did not turn up anything helpful, so I am grateful for any help :)

  • As far as I know Plymouth should not be. used on installed Antergos, as it is causing problems, we only have it active for the live ISO.

  • @joekamprad said in Plymouth often causing boot freeze after full system upgrade:

    As far as I know Plymouth should not be. used on installed Antergos, as it is causing problems, we only have it active for the live ISO.

    Oh, okay. Can I safely remove it, or do I have to replace it with something?

  • Okay now I am really confused. I don’t think I have Plymouth installed on my system. If it was not preinstalled by the Antergos installer, I am certain I did not install it myself (I hate bootsplash).
    There is no Plymouth package on my system and there is no Plymouth hook in my mkinitcpio.conf. And obviously /bin/plymouth is actually not on my system as well. I have no idea why it would look for it.

    I am not even sure anymore if all this funny plymouth business is the cause of my problem.

  • @desmond systemd emergency.service
    Is giving the message… So may it is only logspam

  • Now the title of the thread is messed up if the problem is probably not plymouth. Should I open another thread to figure out my boot problem? (This time with a more generic title haha)

  • @desmond I can have a look into your logs in a minute…

  • This post is deleted!
  • on a short check i can see that on failed log lightdm is not loading, and on successe log it is…

    can you provide systemsumup?

    lspci -v
    
  • More logs of today’s boot attempts

    failed boot 1
    failed boot 2
    failed boot 3
    failed boot 4
    failed boot 5
    failed boot 6
    successful boot

    I should note that for the first 6 failed attempts I had my second monitor connected and for the last and successful attempt I had it disconnected. Previously I had also just one monitor connected and it failed a few times, so this can’t be the solution. But I did make changes to my monitor configuration before all this started.
    In ccsm I changed the outputs in the display setting to fix a bug where my maximized windows would spread across both monitors. Not sure if this is related, but it might.

    Also it is worth noting that it seems like the first boot attempt always fails

    Here is the systemsumup:
    lspci

  • Got the same problem here. Done an update on Sunday (I think), starting the first time this evening and got to the emergency shell.

    • pressing ctrl-d to boot anyway worked
    • installing plymouth fixed the problem but plymouth failed to start (which is fine)
    • removing plymouth, got the emergency-prompt again
    • grepping for plymount in /usr got me usr/lib/systemd/system/emergency.service as a result

    Resolution
    commenting out

    ExecStartPre=-/bin/plymouth --wait-quit
    

    in /usr/lib/sytemd/system/emergency.service fixed the problem.

    Still wondering how it got into it. Any ideas? I did not find any obvious changes or commits in the systemd arch-package .

  • @inw That might have fixed my Plymouth problem, but sadly not my actual problem of boot freezes. Which despite the title might not be related to Plymouth at all.

  • The problem has solved itself. Presumably with some upgrade.

boot271 freeze29 causing3 plymouth3 Posts 13Views 463
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.