• EHCI loaded incorrectly


    Checking my dmesg outputs I noticed a warning about ehci_hcd module which says:

    Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, not after
    

    Causing some other errors:

    pci 0000:00:12.0: quirk_usb_early_handoff+0x0/0x6c6 took 78473 usecs
    pci 0000:00:13.0: quirk_usb_early_handoff+0x0/0x6c6 took 71414 usecs
    pci 0000:00:14.5: quirk_usb_early_handoff+0x0/0x6c6 took 71438 usecs
    pci 0000:00:16.0: quirk_usb_early_handoff+0x0/0x6c6 took 71602 usecs
    
    QUIRK: Enable AMD PLL fix
    

    Where I can find the modules list and reorder to not make my system “quirk”?

  • My workaround was loading ehci_hcd in mkinitcpio.conf then the warning message disapear but not the “quirk” ones, maybe something else related?

  • @edwin-foss said in EHCI loaded incorrectly:

    QUIRK: Enable AMD PLL fix

    Well, the part I quoted is NOT a error message so there’s nothing you can do to make the “Quirk” go away.

    This is the kernel telling you that it enabled the “AMD PLL fix” for the “Quirk” (a hardware bug) present in the USB root complex(es) of the EHCI(?) controller.

    Depending on how buggy the many chips on your motherboard are you may actually see a whole lot more “Quirk” messages in your system log during kernel init / system boot. They are not a error message per-se, they are just there to inform you that a certain chip/component on your board has a hardware bug . The definition of it being a problem or not is ultimately up to you … depending on whether or not it works as expected.

loaded4 incorrectly2 ehci1 Posts 3Views 229
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.