• No more sound, no card detected


    I have no more sound since some days. Before it was working fine and I don’t remember doing something special.

    lspci shows this;
    “00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)”

    inxi -Fx shows this:

    Card-1: Intel CM238 HD Audio driver: snd_hda_intel v: kernel
    bus ID: 00:1f.3
    Sound Server: ALSA v: k4.17.4-1-ARCH

    But pulseaudio drops only to “dummy output”, in the configuration part of pavucontrol, I read “no card available…”, alsamixer shows only pulseaudio and I do not know how to add to it the default card.

    It’s probably something silly but I can’t find a solution.

    Silence all the way. Maybe the most practical would be to uninstall properly everything alsa and pulseaudio related?

  • @roger64 said in No more sound, no card detected:

    pulseaudio drops only to “dummy output”

    I’ve noticed some change in pulseaudio package, one doesn’t exist anymore or was renamed, so i believe after some upgrade the system removed the package from your system and you need to reinstall it (or install the new one),

    Maybe the most practical would be to uninstall properly everything alsa and pulseaudio related?

    I guess so…

  • I reinstalled pulseaudio, linux and linux-headers (because of no sound modules), rebooted. Thingslooked wrong and I was left on a prompt, and advised to try: journalctl -xb and then exit.

    I had to stop with the on/off button. I was sure I would have to reinstall everything, restarted, got a thirty seconds black screen and finally found myself back on Antergos, up and running, with the sound working again.

    I don’t really understand what happened but it’s solved.

    Another detail that plagued me several weeks. When exiting, I had a 30 seconds delay due to “a stop job for uid 1000”… No way to suppress it. Now it’s gone, as mysteriously as it arrived…

    Stay tuned, strange things happening.

  • This is solved but I do not manage to declare it solved in the first post. Sorry.

sound62 detected17 Posts 4Views 536
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.