• USB mounting didn't work


    If I plugin an USB-HDD (one partition, fat), antergos recognized, that the device is plugged in, but is not able to mount it.

    If I open the device in Thunar, I got the message:

    Unknown error when mounting

    If I open the cli and enter: sudo mount /dev/sdb1 /mnt I got back to cli-prompt without any error… but the device is even NOT mounted.

    fdisk -l:
    Gerät Boot Anfang Ende Sektoren Größe Kn Typ
    /dev/sdb1 63 976768064 976768002 465,8G c W95 FAT32 (LBA)

    lfsck.vfat /dev/sdb1 (first run fix some stuff, second run, no errors)

    fstab:

    cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    #
    UUID=94d6766d-93ad-4f43-a42b-b54e075ad292 /boot ext4 defaults,rw,noatime,discard 0 0
    UUID=f06310d0-faa6-44f7-81ff-aa8f2f9b25c4 swap swap defaults 0 0
    UUID=83916608-6c8c-42d1-a805-e652f16c994c / ext4 defaults,rw,noatime,discard 0 1
    
    
  • This is in dmesg if I plugout and plugin again:

    [ 2216.432576] usb 1-1.1: new high-speed USB device number 9 using ehci-pci
    [ 2216.530723] usb 1-1.1: New USB device found, idVendor=18a5, idProduct=022b, bcdDevice= 0.00
    [ 2216.530731] usb 1-1.1: New USB device strings: Mfr=10, Product=11, SerialNumber=12
    [ 2216.530736] usb 1-1.1: Product: Portable USB Drive
    [ 2216.530740] usb 1-1.1: Manufacturer: Verbatim
    [ 2216.530744] usb 1-1.1: SerialNumber: 29501X068962
    [ 2216.531665] usb-storage 1-1.1:1.0: USB Mass Storage device detected
    [ 2216.535518] scsi host6: usb-storage 1-1.1:1.0
    [ 2217.546966] scsi 6:0:0:0: Direct-Access     ST950032 5AS              0002 PQ: 0 ANSI: 2 CCS
    [ 2217.547599] sd 6:0:0:0: Attached scsi generic sg2 type 0
    [ 2217.549712] sd 6:0:0:0: [sdb] 976773168 512-byte logical blocks: (500 GB/466 GiB)
    [ 2217.551100] sd 6:0:0:0: [sdb] Write Protect is off
    [ 2217.551105] sd 6:0:0:0: [sdb] Mode Sense: 28 00 00 00
    [ 2217.552486] sd 6:0:0:0: [sdb] No Caching mode page found
    [ 2217.552496] sd 6:0:0:0: [sdb] Assuming drive cache: write through
    [ 2217.626715]  sdb: sdb1
    [ 2217.633370] sd 6:0:0:0: [sdb] Attached SCSI disk
    [ 2314.828834]  sdb: sdb1
    [ 2330.764910]  sdb: sdb1
    [ 2353.417231]  sdb: sdb1
    [ 2353.430103]  sdb: sdb1
    
    
  • @rethus said in USB mounting didn't work:

    This is in dmesg if I plugout and plugin again:

    Try issuing a blkid command

    [email protected] ~]$ sudo blkid
    [sudo] password for joeblow:
    /dev/sda1: LABEL=“BOOT” UUID=“48ac1fd7-232e-4c26-b1e5-add47fe5bf49” TYPE=“ext4” PARTUUID=“75ecdd5e-01”
    /dev/sda2: LABEL=“ROOT” UUID=“721514e4-3672-43a6-b0cf-0e076d6db6cd” TYPE=“ext4” PARTUUID=“75ecdd5e-02”
    /dev/sda3: LABEL=“SWAP” UUID=“45f8bde3-aff2-4544-8fe4-5388982d89ad” TYPE=“swap” PARTUUID=“75ecdd5e-03”
    /dev/sda4: LABEL=“HOME” UUID=“3ca8aea6-ad03-43c6-8e56-3dac8140e655” TYPE=“ext4” PARTUUID=“75ecdd5e-04”
    /dev/sdb1: LABEL=“TEMP” UUID=“1285-3CA3” TYPE=“vfat” PARTUUID=“00010e14-01”

    If the filesystem recognizes the USB Drive it will list it and display the formatting.
    If it doesn’t list it, then udev and whatever else is involved in detecting a hot plugin on the USB port is not detecting it.

    FYI Gnome mounts usb drives on
    /run/media/username/

    I don’t think it is advised to manually mount stuff on /mnt
    Perhaps Joe or Emanuel can further clarify that.

    HTH

  • @pudge
    Addendum (SInce you can’t edit posts)
    The output of blkid (must be run as root) also shows why it is important to use Labels for each partition that clearly state what the individual partitions are.

usb95 mounting6 Posts 4Views 62
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.