• Some music players will not start

    Good evening (at least over here).

    I would like to report that Clementine did not start at all today when I was going to listen to some music (.ogg file and .mp3). This is a fresh install of Antergos with KDE desktop which I did yesterday on my new laptop (have had it for 3 days now).
    At that time I tried to uninstall (remove) through the add/remove application, but it was not possible. I honestly don’t remember what the error box said. I however could uninstall Clementine after reboot. I then tried to install and use Amarok (since it is a KDE based), but had exact same problem.
    Going through journalctl -f and journalctl -b -1 did not give me any idea what was happening. Then again, I don’t have the exact time of when I was trying those applications.

    I solved this by using VLC as my player, but I thought that you might want to know about this issue.
    I used screenfech because I was too lazy to find alternative for inxi:

                .-/osssssssso/.               [email protected]
               :osyysssssssyyys+-             OS: Antergos 
            `.+yyyysssssssssyyyyy+.           Kernel: x86_64 Linux 4.17.4-1-ARCH
           `/syyyyyssssssssssyyyyys-`         Uptime: 6h 8m
          `/yhyyyyysss++ssosyyyyhhy/`         Packages: 1220
         .ohhhyyyyso++/+oso+syy+shhhho.       Shell: bash 4.4.23
        .shhhhysoo++//+sss+++yyy+shhhhs.      Resolution: 1920x1080
       -yhhhhs+++++++ossso+++yyys+ohhddy:     DE: KDE 5.47.0 / Plasma 5.13.2
      -yddhhyo+++++osyyss++++yyyyooyhdddy-    WM: KWin
     .yddddhso++osyyyyys+++++yyhhsoshddddy`   WM Theme: Breeze
    `odddddhyosyhyyyyyy++++++yhhhyosddddddo   GTK Theme: Numix-Frost-Light [GTK2/3]
    .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh.  Icon Theme: Numix
    ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy  CPU: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx @ 8x 1.6GHz [44.0°C]
    dmmmdddddddhhhyso++++++shhhhhddddddmmmmh  GPU: AMD RAVEN (DRM 3.25.0, 4.17.4-1-ARCH, LLVM 6.0.0)
    -dmmmdddddddhhyso++++oshhhhdddddddmmmmd-  RAM: 3780MiB / 4918MiB
  • What does the output say when you start the player from the terminal?

  • I honestly didn’t try that. I can install Clementine again and check it out if you like.

  • So I just installed Clementine, and I think I started the application right in terminal (bit of a noob).

    [[email protected] ~]$ clementine
    clementine: error while loading shared libraries: liblastfm.so.1: cannot open shared object file: No such file or directory

    I can still see the it in my startup menu.

  • @olividir said in Some music players will not start:

    clementine: error while loading shared libraries: liblastfm.so.1: cannot open shared object file: No such file or directory

    Check if you have installed liblastfm-qt4 or liblastfm-qt5. Maybe ou need the qt5 version.

  • I have liblastfm-qt5 installed, so that is not the problem.

    I have resolved this problem by moving to VLC :)
    Just wanted to let the developers know.

  • olividir–At this time Clementine and Amarok are still qt4 applications. Perhaps liblastfm-qt4 is the one you need. As far as I know qt4 and qt5 can coexist but Clementine and Amarok need qt4 libraries until they upgrade their applications.–falcon40

  • olividir–Your observation is able to be repeated and your note for the developers is helpful (if they see it). The solution for Clementine (did not test on Amarok) is to uninstall liblastfm-qt5 and install liblastfm-qt4. Contrary to my previous post they will not coexist. Not sure how this will impact other programs although it seems logical that programs needing liblastfm-qt5 will suffer. This is likely one of the reasons many GNU/Linux distributions have stopped offering Clementine and Amarok as default applications. Default applications should work without any adjustments.–falcon40

  • Well, those are good news. I don’t know if I will use them because I am perfectly fine using VLC :)

    Thank you for the answer though :)

clementine9 music player6 kde-plasma4 Posts 9Views 643
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.