• 3G HSPA USB Modem problem

    Hi everyone! Hope you’re all having a nice life! :) I’ve been having some problems with my wired DSL connection, actually, at the moment it doesn’t work. I got this Huawei Technologies Co., Ltd. Broadband stick 3G usb modem from a friend so I can connect to the internet in the meantime the problem’s being solved. When I first plugged it in everything went just fine, I only had to set it up using the network manager and then select the just created connection an that was it. Since this thing doesn’t provide unlimited internet access but 2GB a month only, I have to keep an eye on the traffic so it doesn’t get beyond that limit. The modem comes with a software, since I’ve seen it working on windows before I know it shows traffic stats so people can keep track of the 2GB plan. For Linux there’s a folder called “Linux” and inside it there’s a .sh install file, so I ran it. It all went well and soon after installation was finished the program started but it didn’t work, I mean, when I hit connect, it didn’t. So I closed it and went to network manager just to find out that the usb modem didn’t show anymore, it wasn’t available to select. After a few tries I decided to uninstall the program, and then the modem became available to select again, now everytime I unplugged it and plugged it in I have to install and uninstall the program so it comes available to select. Any Ideas? Suggestions? Thanks in advance for your answers.

  • I would take a look if there is a browser config option aviable… so that you can do check inside your browser without any special software…

    Without the exact Model specifications it would be great luck to find somone here with the same device in use…

  • @joekamprad Hi and thanks for your answer. Actually, I’m using nload and vnstat to keep track on how much of the 2GB plan is being used, I wanted to use the software cause it’s more much easier. Regarding the exact model specification I’m quite not sure, I’d have to ask my friend about it cause I’ve been googling for a way to find out but so far I haven’t had any luck. Sudo lsusb shows this:
    Bus 002 Device 004: ID 12d1:1436 Huawei Technologies Co., Ltd. Broadband stick
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 2.00
    bDeviceClass 239 Miscellaneous Device
    bDeviceSubClass 2
    bDeviceProtocol 1 Interface Association
    bMaxPacketSize0 64
    idVendor 0x12d1 Huawei Technologies Co., Ltd.
    idProduct 0x1436 Broadband stick
    bcdDevice 0.00
    iManufacturer 4 HUAWEI Technology
    iProduct 3 HUAWEI Mobile
    iSerial 0
    bNumConfigurations 1
    Configuration Descriptor:
    As far as I read, it seems to me it has something to do with usb_modeswitch, but then again I have no experience with this kind of problems. I tried something I read in a post but that didn’t work, maybe I did it all wrong not sure. The only way I get the usb modem to work is by installing and uninstalling the software, then and only then I can select the connection from network manager. I hope the dsl wired problem is solved real soon! :)

usb117 modem4 hspa1 Posts 3Views 364
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.