• How to stop pacman timeout


    Hi, it’s been a year since my city got Gigabit fiber networks and it’s still getting problems once a while, every time something goes wrong my pacman timesout after 10sec every single server is like that, the problem is in our service provider, i can install everything through the browser but its tedious, i previously found a solution (Adding options timeout:1 to the end of resolv.conf) but it gets back to normal after restart, is there a permanent fix?

  • Hi,

    If you’re using Antegos default setup, it uses NetworkManager to create your /etc/resolv.conf, so you cannot edit that file manually (it is recreated on each boot).

    If you still want to use networkmanager for managing your connections, you should edit:
    /etc/NetworkManager/NetworkManager.conf and try to make your changes there.

    Unfortunatelly I have no clue what needs to be done to tell Networkmanager to add that timeout:1 option to resolv.conf

    You can check the manual:
    man networkmanager.conf

    The other option (that I do not know if it’s easier or harder) would be to use systemd-resolved to manage your dns setup.

    https://wiki.archlinux.org/index.php/Domain_name_resolution#Systemd-resolved

pacman122 stop15 timeout3 Posts 2Views 419
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.