• During booting fails (Network Synchro/Color Profiles)


    /home/.thunderbird will not work as @fernandomaroto said it is ~/.thunderbird
    where the ~ is a short cut for /home/username
    so for example in my case it is /home/blaise/.thunderbird

    It is unclear what you copied as backup of the home directory.
    If it was the /home directory then the .thunderbird directory should be at path_to_backup/username/.thunderbird
    where username is the user name you used for the system you backed up.

    if it was the just user home directory that you copied, then it should be at path_to_backup/.thunderbird

    HTH

  • I did see that you tried ~/.thunderbird but that is meant to work under the assumption that the usernames you used are the same.

    I guess what I’m trying to say is to solve this problem lets use /home/username, as it is unambiguous.

  • It would help if can you state the path to the backup directory is, and may be list its contents.

  • Finally I got it …yeeeeessss ☺

    So now comes the next step - when install the new o/s after formatting the hard disc which file has to be imported to the new installed Thunderbird?

    It should be this one I think: 0_1532809225894_822b9bac-fa06-4297-a94b-e9191a4b7a00-undefined

    And then?

    0_1532809599487_40bff276-95d3-43e9-b5bf-82a8787d9d85-undefined

    A very big thank you to all of you … Now I have to take the last step = the import

    I count on you… ☺

  • This post is deleted!
  • @blaised - you are exactly on spot

    Is this what I did and it worked to my astonishment ☺

    Thanks

    But I did not have a back up file / the system crashed - and I had to learn everything to get the directory from the crashed laptop
    to be honest I did neither know what ~ meant - In a way a total beginner

    But once I install the new o/s I would like to learn a lot of things - is easier than on chroot

    Normally I use a german key board - chrooting into hd - it was only the english keyboard possible and I had always to tip around in order find the special signs uuffffff ☺

    thanks again to all

  • By convention file and directory names starting with ‘.’ are considered hidden files and often are not visible in File manager/browsers unless the ‘show hidden files’ setting is on.

    The simplest and to my mind the best way to copy the . thunderbird directory is to use the terminal and command line, so login as the user and in terminal something like
    cp -r path_to_my_backup/.../.thunderbird ~/
    should do the job.

  • @blaised

    cp -r path_to_my_backup/…/.thunderbird ~/

    Exactly like above with … the ~/ at the end? o

    So after installing the new o/s I will install Thunderbird Mail … and then do your command?

    How you do it that the comm ands are black embedded?

    I will do tomorrow the install - Thank you for your valuable help…

  • Yes with the ~/ at the end, alternatively /home/username
    I usually copy or link ~ /.thunderbird before firing up Thunderbird on a new install,
    I run multiple distributions, at the moment I use Antergos, OpenSuse, Ubuntu (latest) and Ubuntu LTS.
    I share thunderbird and some other bits across the distributions.
    Keeping user id and group ids the same across the distributions makes this possible. Also implicit reliance on the fact that potentially different Thunderbird versions do not mess things up.
    It works for me, but I do backup stuff just to be on the safe side.

    To do the commands in black embedded I added 3` at the start and another 3 at the end.
    Though interestingly single quotes seems to work just as well :-).

  • Correction that should be single back quotes

  • @blaised Thanks a lot for all the info

    So through terminal with the cp command … to home/user/.thunderbird the data have been transferred…

    but unfortunately when I open Thunderbird Mail only the new emails are shown, which have not yet been read/downloaded - the “old” ones are not listed under “incoming emails”

  • @lamda-delta
    If you do the following command:

    ls -la ~/.thunderbird/
    

    what do you see? Do you see one folder, “.thunderbird”, or many files?

    If you see only .thunderbird under ~/.thunderbird, then the restoring copy was not right.

    Another reason might be the backup command, maybe you didn’t preserve timestamps?

    So the backup command should have been something like:

    cp -a /home/"yourname"/.thunderbird /path/to/backup/folder/
    

    Instead of option -a you could have used option --preserve=timestamps. But if the backup folder has FAT32 file system, I’m not sure if the timestamps prevail.

    And the restore command:

    cp -a /path/to/backup/folder/.thunderbird /home/"yourname"/
    

    More info about cp on the manual page:

    man cp
    
  • @manuel - Thank you very much for your detailed explanation

    The backupfolder / external hd has ext4 - as I am tired I will try your propositions tomorrow
    thanks again - I do appreaciate it

    In the meantime I was able to see the emails in normal formats - and I do know my flight codes - airlines - departure days / times ☺ uuuuff I can breath normally again… ☺ - I took screenshots

    So in Thunderbird - I went to help - and then troubleshooting information

    0_1532892534683_130b7243-6826-4c5b-bd3b-f6b27812d9b8-image.png

    And then Open Folder
    0_1532892716194_3802267c-2f9c-44a6-be36-8cfaef8c8983-image.png

    So I opened the external harddisc , where last night after chrooting to my old system I could copy /transfer
    the .thunderbird file - and so I could see 1:1 the missed emails…

    I did also an Import - but did not find at once the imported files

    Now I am tired - but all in all the mission is fullfiled - I got the travel documents of the family…
    it took me long - but I learned also a lot … also thanks to the nice people in this forum

    THANK YOU

  • @manuel

    For the target folder - why you stop in your command … with “yourname”?

    Is it because on the targetfolder the sourcefolder (last position) .thunderbird will be automatically copied?

    \cp -a /path/to/backup/folder/.thunderbird /home/“yourname”\

    Thanks -

  • Yes, .thunderbird will be assumed to be the target directory, though it also works if you use /home/“yourname”/.thunderbird

    I hope your installation is configured to use IMAP instead of POP, otherwise you may lose the newer email. For safety do not delete your current .thunderbird directory just rename it,
    and try again.
    As @manuel requested, it would be useful if you show us the contents of your .thunderbird directory using ls -la
    mine looks like this

    drwxr-xr-x 1 blaise 100    94 Jan  9  2015  .
    drwxr-xr-x 1 blaise 100  7056 Jul 25 14:20  ..
    drwxr-xr-x 1 blaise 100 10318 Jul 30 15:43  5ixluflx.default
    -rw-r--r-- 1 blaise 100   335 Oct 26  2010  appreg
    drwx------ 1 blaise 100  5366 Jul 25 14:13 'Crash Reports'
    -rw-r--r-- 1 blaise 100   104 Oct 26  2010  profiles.ini
    

    there are sub directories in .thunderbird so you should always use cp -r (-r == recursive copy => copy sub directories),
    Perhaps as @manuel suggested cp -r --preserve=timestamps is better, I don’t know.

    I’ve been copying my .thunderbird directory for years, across desktop machine upgrades and to the laptops. It has always worked and is simple to do.

    To check that you have got it correct do ls -la on the source directory and then the target directory and compare the results.
    They should so be the same, excluding perhaps the time stamps, and user and group ids (depends on the command you used to copy).

    HTH.

  • @blaised Hi blaised - thank you for your wonderful explanations -

    I think I will bookmark this thread - there are so informative posts that I can use for any kind future problems that might come.

    Today is the National Day of Switzerland (God shall protect all the Nations of the World) so I am not working and I have time for tinking.

    blaised, as it was on POP modus during the installation of new O/S I re-opened the accounts on POP modus - but
    now as all messages are in … in the new installed Thunderbird ☺ - I will change it to IMAP.

    So there is an other quick and “dirty” method, which is windows like - and I got now all the messages the new ones (although POP modus) and the old ones too.

    And it goes like this:

    “Elements” is the external harddisc in which thanks the help of all of you - I could copy thunderbird profile from the crashed o/s
    0_1533140753974_9e8be9b7-1be1-4ea5-b162-2dab4888dbdc-grafik.png

    So I opened the Thunderbird Profile directory “axq1rtr.default” copied all the files

    then went to the installed Thunderbird of the new o/s system (still Antergos) and through…
    0_1533141021139_a17ffe36-da9d-4a4a-a4ce-eda69a425cdb-grafik.png

    0_1533141108237_d097e178-dc25-49d5-94cc-85b4cf5ed54c-grafik.png

    … I went to the equivalent new installed Thunderbird profile and there I copied the mentioned files

    During this process the system asks “Shall the files (old and new ones) be merged”? - YES
    “Shall the files be replaced”? YES

    That’s it - Thanks to all again - you were all very helpful and I learned a lot from you.

    @ moderators - I will put this thread as Solved - if you could complete the title of this topic - with copying Thunderbird Profile from a crashed System … it would fit better to “history” of this thread.

    My sincere thanks to all of you and your time replying to me…

    PS. What still not works to embed black the written commands here ☺

  • @lamda-delta
    Sorry, editing posts is not working with the current forum software. :(

  • @manuel No worries… ☺

booting55 fails51 during35 synchrocolor1 Posts 38Views 1190
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.