• PyCharm can not resolve Gtk

    Sorry for asking the question in no way related to Antergos itself, but @karasu is my only hope for an answer. ;)

    The picture below should describe the problem well enough:


    The code works well, but I’d like to have autocompletion, which refuses to work. I tried adding __all__ = ['Gtk'] to the __init__.py file, as advised here. I also increased the idea.max.intellisense.filesize value in idea.properties and tried to “Generate stubs for binary module”. Nothing helps. Some people on the web claim it doesn’t work in PyCharm at all. The others managed to resolve the issue. Surely I can live without it, but it wolud be great not to have to look into documentation again and again.

  • Hi,

    To be honest, I’ve never used this function…

    Are you using latest pycharm version?

    Have you tried this?


    (idea.properties in /opt/idea/bin in my comp).

    Oh, every time you make some change (like adding __all__ to your __init__.py file) remember to clear your cache:
    PyCharm menu select: File --> Invalidate Caches / Restart

    Hope this helps.

  • Hello and thanks for replying,

    Yes I’m on the latest PyCharm version, and tried all above. Currently I tend to think something must be wrong about my __init__.py content. This is still kinda mystery to me. :)

gtk20 resolve5 pycharm1 Posts 3Views 729
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.