• KDE Plasma settings (and look and feel)

    Most KDE settings window seems to have the content pane blank/empty. This has only occurred in the last 2 weeks
    I’ve noticed this issue on existing Antergos VMs and a new VM.

    I’m on: plasma-desktop 5.13.2-1

    When I run: kcmshell5 kcm_lookandfeel, I get the following message:

    org.kde.kcoreaddons: Error loading plugin "kcm_lookandfeel" "The shared library was not found." 
    Plugin search paths are ("/usr/lib/qt/plugins", "/usr/bin") 
    The environment variable QT_PLUGIN_PATH might be not correctly set

    The issue is exactly like these ones:

    They recommend installing sudo apt install qml-module-org-kde-kcm but that’s not an Arch package

    I have the following “qml” packages installed:

    • extra/accounts-qml-module 0.7-1 [installed]
    • extra/kdeclarative 5.47.0-1 (kf5) [installed]
    • extra/plasma-nm 5.13.2-1 (plasma) [installed]
    • extra/qt5-declarative 5.11.1-1 (qt qt5) [installed]
    • extra/qt5-webchannel 5.11.1-1 (qt qt5) [installed]
    • extra/qt5-webkit 5.212.0alpha2-18 (qt qt5) [installed]
  • This forum software is atrocious! Can even edit a question/message

    ^^ title should be: KDE Plasma settings 5.13.2 content pane is blank/empty

  • Regarding the forum software, the devs don’t make the forum software, they just use it as a graphical base for all it’s users.
    They are not the authors of the software that this discussion forum uses.
    You’d have to lodge your complaint with the proper management.
    I"m not proper management.

    now to get to the real concern here:

    Have you tried or perhaps you already have installed
    accounts-qml-module 0.7-1

  • Thanks @modisc, I checked that accounts-qml-module was installed.

    I have a little more information regarding this issue:

    From a fresh install of Antergos (KDE) + Linux LTS using VirtualBox, settings are visible.

    • confirmed: virtualbox-guest-dkms and virtualbox-guest-utils were installed as part of cnchi installation
    • glxinfo: server glx vendor string: SGI (software rendering)
    • glxgears: 24fps
    • KDE Settings are VISIBLE

    After running VBox Guest services ISO

    • glxinfo: server glx vendor string: Chromium (hardware rendering)
    • glxgears: 150fps
    • KDE Settings are NOT VISIBLE

    So it’s a bit of a lose/lose situation, I have to choose either hardware graphics support OR visible settings 😭

  • I gave up - Installed Antergos KDE on bare metal, there always seems to be something wrong when using VirtualBox.

    Will have to work out how to snapshot my drive now

  • hi. Terrible sorry for my tardy response and that I wasn’t able to get to you in time to help compose and answer for you.
    but if installing as per your solution is working for you, then that’s good then. :)

kde206 plasma48 feel3 Posts 7Views 1197
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.