• Use Deepin login screen at boot instead of Antergos default


    How can I use the Deepin default screen instead of the Antergos login when I first boot up the system?

    I am getting a screen with the time and an Antergos logo, and a text box appears when I click the time. I would like it to be consistent with the rest of my system, and I have to say, the Deepin login looks much better. Sorry, I don’t know how to take a screenshot of the login.

    I also see a dropdown with desktop environment options ( I think; Deepin is the only option ) so I think the issue might be solved if Antergos automatically boots into Deepin, or something like that.

    Thanks!

  • Open your terminal and type the following command:

    sudo nano /etc/lightdm/lightdm.conf
    

    Then go with your arrow key down to the line:

    greeter-session=lightdm-webkit2-greeter
    

    and change it into:

    greeter-session=deepin-session-ui
    

    Then go to the end of the text and save it. (underneath the screen you’ll see how you can do that and ^ is the control key, in case you don’t know)
    Restart and your system will start with the official Deepin greeter.

  • Nope, that gives an error about Light Display Manager failing to start at boot.

  • There are two lines that start with greeter-session.
    The first one has a # in front of it, that one should be left alone
    It’s the second line without the # in front of it that should be changed. It is almost underneath the script.

  • as far as i can see it must be greeter-session=lightdm-deepin-greeter or i am wrong?

  • @joekamprad
    That’s the old deepin greeter, the deepin-session-ui is the one that also comes with Antergos deepin package, but isn’t enabled by default.

  • The most important thing is that the second line of greeter-session is changed and not the first line with the # in front of it.

  • I thought I changed the second line, but I’ll try again.

  • @bryanpwo said in Use Deepin login screen at boot instead of Antergos default:

    Antergos deepin package

    0_1530863570903_Bildschirmfoto vom 2018-07-06 09-52-33.png

    Or is it another package?

  • @joekamprad
    Yes it is, I’ve got the workaround from another thread on the internet some months ago, because the lightdm-deepin-greeter line didn’t work and it always worked. I’m going to install Deepin in a VM and let you know if the workaround still works. The last time I’ve used Deepin was 2-3 months ago and it worked. I even passed it on on this forum and it also worked for the people who asked for it.

  • I’ve tried the option with deepin-session-ui and lightdm didn’t start, in the lightdm-deepin-greeter option all I’ve got was a white screen with a blinking cursor. After entering my pw Deepin started, but when closing down the white screen reappeared.
    I’ve tried it in a VM and on an actual machine, both with the same result.

  • @bryanpwo same here ;)

  • Yeah, neither of them work.

  • @mofei

    Do you have in the meantime found a solution?

    And a question regarding the deepin dock, is there a way to make it transparent?

    Greettings

boot302 login131 deepin67 Posts 14Views 963
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.