• office 2010 errors after wine install


    I installed Wine using these instructions:

    Microsoft Office Word encountered a problem and needs to close. We are sorry for the inconvenience.

  • Try setting the Windows version in winecfg to XP. Also, after installing, set riched20 to native, builtin in winecfg to allow some of the selection boxes to display properly and for Powerpoint to launch. (From https://appdb.winehq.org/objectManager.php?sClass=version&iId=17336)

  • Weird. Now Powerpoint works. When I try to launch either Word or Excel I get a second Window that launches saying “Please wait while setup prepares necessary files”, then the Program error box comes up again saying that setup.exe has encountered a serious problem. maybe some other settings needed in winecfg Libraries?

  • As far as I remember, vcrun2010 is still required.
    For applications (not for games), imho, it is better to use playonlinux. There is a community adjusts on the basis of various nuances.

  • @tuxnot I already tried PlayonLinux with no success. Playonlinux has never been able to run office on Arch.

  • It’s a pity. If nothing happens, then it remains to try crossover and Microsoft Online Apps.
    I made OneDrav with ice-ssb.
    alt text
    If you do, it may look like this: Need Microsoft Office on Ubuntu? Install the Official Web Apps .
    Can try to convert deb (microsoft online apps) to pkg.tar.xz . But believe me, through ice is very easy, just a link to insert.

  • @tuxnot said in office 2010 errors after wine install:

    It’s a pity. If nothing happens, then it remains to try crossover and Microsoft Online Apps.

    I can confirm it works perfectly with Crossover, as does O2k13. Kinda defeats the purpose of FOSS, though. I needed Office for a collaboration I was working on a while back and the others thought I “needed” it.

    Silly Windows fanboys, always thinking you gotta spend money…

  • I tried crossover about a year ago and had issues. Not really keen on paying when it works on Wine and POL for free.
    Not just an Arch thing though, I noticed it installs flawlessly in POL in previous Ubuntu versions. The latest Ubuntu 18.04 is a mess trying to install it. It works perfect in Debian too.

wine24 office8 20102 Posts 9Views 719
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.